about summary refs log tree commit diff
path: root/nixos/modules/services/games/ghost-one.nix
diff options
context:
space:
mode:
authorJoachim F <joachifm@users.noreply.github.com>2016-11-05 12:18:04 +0100
committerGitHub <noreply@github.com>2016-11-05 12:18:04 +0100
commit2c567dbd4d09eeb9c4cbda1ac3681cf74b9e4980 (patch)
tree3fdc29f1664e313620d783dec510e7749dca2c76 /nixos/modules/services/games/ghost-one.nix
parent2df4d24a7484fd8d9447d242290846a3f67ca71c (diff)
parent986510de4562c532beb3c9d794f56e2d8015c9fc (diff)
downloadnixlib-2c567dbd4d09eeb9c4cbda1ac3681cf74b9e4980.tar
nixlib-2c567dbd4d09eeb9c4cbda1ac3681cf74b9e4980.tar.gz
nixlib-2c567dbd4d09eeb9c4cbda1ac3681cf74b9e4980.tar.bz2
nixlib-2c567dbd4d09eeb9c4cbda1ac3681cf74b9e4980.tar.lz
nixlib-2c567dbd4d09eeb9c4cbda1ac3681cf74b9e4980.tar.xz
nixlib-2c567dbd4d09eeb9c4cbda1ac3681cf74b9e4980.tar.zst
nixlib-2c567dbd4d09eeb9c4cbda1ac3681cf74b9e4980.zip
Merge pull request #20144 from ericsagnes/feat/module-enums
modules: use enum when relevant
Diffstat (limited to 'nixos/modules/services/games/ghost-one.nix')
-rw-r--r--nixos/modules/services/games/ghost-one.nix3
1 files changed, 1 insertions, 2 deletions
diff --git a/nixos/modules/services/games/ghost-one.nix b/nixos/modules/services/games/ghost-one.nix
index 5762148df2bb..71ff6bb2f3f0 100644
--- a/nixos/modules/services/games/ghost-one.nix
+++ b/nixos/modules/services/games/ghost-one.nix
@@ -21,8 +21,7 @@ in
 
       language = mkOption {
         default = "English";
-        type = types.addCheck types.str
-          (lang: elem lang [ "English" "Spanish" "Russian" "Serbian" "Turkish" ]);
+        type = types.enum [ "English" "Spanish" "Russian" "Serbian" "Turkish" ];
         description = "The language of bot messages: English, Spanish, Russian, Serbian or Turkish.";
       };