about summary refs log tree commit diff
path: root/nixos/modules/services/desktops/gnome3/glib-networking.nix
diff options
context:
space:
mode:
authorworldofpeace <worldofpeace@users.noreply.github.com>2019-04-08 15:11:59 -0400
committerworldofpeace <worldofpeace@users.noreply.github.com>2019-04-15 13:04:06 -0400
commitb0e9f85f47506713eea6b69e14bf67e0929d2a7d (patch)
treedaafd63ee5c410b9d67b890cec5f758e742b15a0 /nixos/modules/services/desktops/gnome3/glib-networking.nix
parent05a53ecd827c5910e34171e7681c56913b29add1 (diff)
downloadnixlib-b0e9f85f47506713eea6b69e14bf67e0929d2a7d.tar
nixlib-b0e9f85f47506713eea6b69e14bf67e0929d2a7d.tar.gz
nixlib-b0e9f85f47506713eea6b69e14bf67e0929d2a7d.tar.bz2
nixlib-b0e9f85f47506713eea6b69e14bf67e0929d2a7d.tar.lz
nixlib-b0e9f85f47506713eea6b69e14bf67e0929d2a7d.tar.xz
nixlib-b0e9f85f47506713eea6b69e14bf67e0929d2a7d.tar.zst
nixlib-b0e9f85f47506713eea6b69e14bf67e0929d2a7d.zip
nixos/glib-networking: init
Note that we were previously didn't have glib-networking
in systemd.packages so the PacRunner was non-functional.
Diffstat (limited to 'nixos/modules/services/desktops/gnome3/glib-networking.nix')
-rw-r--r--nixos/modules/services/desktops/gnome3/glib-networking.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/nixos/modules/services/desktops/gnome3/glib-networking.nix b/nixos/modules/services/desktops/gnome3/glib-networking.nix
new file mode 100644
index 000000000000..186668d7d385
--- /dev/null
+++ b/nixos/modules/services/desktops/gnome3/glib-networking.nix
@@ -0,0 +1,33 @@
+# GLib Networking
+
+{ config, pkgs, lib, ... }:
+
+with lib;
+
+{
+
+  ###### interface
+
+  options = {
+
+    services.gnome3.glib-networking = {
+
+      enable = mkEnableOption "network extensions for GLib";
+
+    };
+
+  };
+
+  ###### implementation
+
+  config = mkIf config.services.gnome3.glib-networking.enable {
+
+    services.dbus.packages = [ pkgs.gnome3.glib-networking ];
+
+    systemd.packages = [ pkgs.gnome3.glib-networking ];
+
+    environment.variables.GIO_EXTRA_MODULES = [ "${pkgs.gnome3.glib-networking.out}/lib/gio/modules" ];
+
+  };
+
+}