about summary refs log tree commit diff
path: root/nixos/modules/rename.nix
diff options
context:
space:
mode:
authorSilvan Mosberger <infinisil@icloud.com>2019-09-15 18:25:40 +0200
committerSilvan Mosberger <infinisil@icloud.com>2019-09-15 18:25:40 +0200
commitecf5f85a81d9ddd5a5c40eabb0e8fba3c8ed7481 (patch)
treea76c6a867c8efc0c31ef49692e61b3458ccdbf1f /nixos/modules/rename.nix
parent0c457cb348c66abfc26abbbccc2b42d78f52d458 (diff)
downloadnixlib-ecf5f85a81d9ddd5a5c40eabb0e8fba3c8ed7481.tar
nixlib-ecf5f85a81d9ddd5a5c40eabb0e8fba3c8ed7481.tar.gz
nixlib-ecf5f85a81d9ddd5a5c40eabb0e8fba3c8ed7481.tar.bz2
nixlib-ecf5f85a81d9ddd5a5c40eabb0e8fba3c8ed7481.tar.lz
nixlib-ecf5f85a81d9ddd5a5c40eabb0e8fba3c8ed7481.tar.xz
nixlib-ecf5f85a81d9ddd5a5c40eabb0e8fba3c8ed7481.tar.zst
nixlib-ecf5f85a81d9ddd5a5c40eabb0e8fba3c8ed7481.zip
nixos/redshift: Move option renames to the module
Diffstat (limited to 'nixos/modules/rename.nix')
-rw-r--r--nixos/modules/rename.nix14
1 files changed, 0 insertions, 14 deletions
diff --git a/nixos/modules/rename.nix b/nixos/modules/rename.nix
index d1303f90ad8d..0c7c45a4708b 100644
--- a/nixos/modules/rename.nix
+++ b/nixos/modules/rename.nix
@@ -273,20 +273,6 @@ with lib;
     (mkRenamedOptionModule [ "networking" "extraResolvconfConf" ] [ "networking" "resolvconf" "extraConfig" ])
     (mkRenamedOptionModule [ "networking" "resolvconfOptions" ] [ "networking" "resolvconf" "extraOptions" ])
 
-    # Redshift
-    (mkChangedOptionModule [ "services" "redshift" "latitude" ] [ "location" "latitude" ]
-      (config:
-        let value = getAttrFromPath [ "services" "redshift" "latitude" ] config;
-        in if value == null then
-          throw "services.redshift.latitude is set to null, you can remove this"
-          else builtins.fromJSON value))
-    (mkChangedOptionModule [ "services" "redshift" "longitude" ] [ "location" "longitude" ]
-      (config:
-        let value = getAttrFromPath [ "services" "redshift" "longitude" ] config;
-        in if value == null then
-          throw "services.redshift.longitude is set to null, you can remove this"
-          else builtins.fromJSON value))
-
     # Redis
     (mkRemovedOptionModule [ "services" "redis" "user" ] "The redis module now is hardcoded to the redis user.")
     (mkRemovedOptionModule [ "services" "redis" "dbpath" ] "The redis module now uses /var/lib/redis as data directory.")