about summary refs log tree commit diff
path: root/nixos/modules/rename.nix
diff options
context:
space:
mode:
authorChristian Kauhaus <kc@flyingcircus.io>2019-11-24 16:38:52 +0100
committerChristian Kauhaus <kc@flyingcircus.io>2019-11-26 11:08:44 +0100
commitdd87e9eb4da1e34df575eb546122809620d05aec (patch)
treecaf39ef92ec528456a171097f4c9fe90fabeae47 /nixos/modules/rename.nix
parent6127bf9837d201bc76d1aa16a85309b161ab07d8 (diff)
downloadnixlib-dd87e9eb4da1e34df575eb546122809620d05aec.tar
nixlib-dd87e9eb4da1e34df575eb546122809620d05aec.tar.gz
nixlib-dd87e9eb4da1e34df575eb546122809620d05aec.tar.bz2
nixlib-dd87e9eb4da1e34df575eb546122809620d05aec.tar.lz
nixlib-dd87e9eb4da1e34df575eb546122809620d05aec.tar.xz
nixlib-dd87e9eb4da1e34df575eb546122809620d05aec.tar.zst
nixlib-dd87e9eb4da1e34df575eb546122809620d05aec.zip
ssmtp: use services.ssmtp.* options
This PR is part of the networking.* namespace cleanup.

ssmtp used to be configured via `networking.defaultMailServer` which is
sort of misleading since it provides options only for ssmtp. Other
dumb mail relays like nullmailer have always been living under
services.

The intent of this PR is to align ssmtp's options with those of similar
services. Specifically, two renames have been done:

* Rename `networking.defaultMailHost` to `services.ssmtp`.
* Rename `directDelivery` to `enable` because this is what it basically does.
Diffstat (limited to 'nixos/modules/rename.nix')
-rw-r--r--nixos/modules/rename.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/nixos/modules/rename.nix b/nixos/modules/rename.nix
index d4bce3b49d36..e392fef54dde 100644
--- a/nixos/modules/rename.nix
+++ b/nixos/modules/rename.nix
@@ -11,6 +11,8 @@ with lib;
     (mkRenamedOptionModule [ "networking" "enableRTL8192cFirmware" ] [ "hardware" "enableRedistributableFirmware" ])
     (mkRenamedOptionModule [ "networking" "networkmanager" "useDnsmasq" ] [ "networking" "networkmanager" "dns" ])
     (mkRenamedOptionModule [ "networking" "connman" ] [ "services" "connman" ])
+    (mkRenamedOptionModule [ "networking" "defaultMailServer" ] [ "services" "ssmtp" ])
+    (mkRenamedOptionModule [ "services" "ssmtp" "directDelivery" ] [ "services" "ssmtp" "enable" ])
     (mkChangedOptionModule [ "services" "printing" "gutenprint" ] [ "services" "printing" "drivers" ]
       (config:
         let enabled = getAttrFromPath [ "services" "printing" "gutenprint" ] config;