about summary refs log tree commit diff
path: root/nixos/modules/rename.nix
diff options
context:
space:
mode:
authorNikolay Amiantov <ab@fmap.me>2017-01-14 14:36:33 +0300
committerNikolay Amiantov <ab@fmap.me>2017-01-15 19:38:53 +0300
commit1158eda66a7646ca8b8204ffbb3d1c55a73d0374 (patch)
tree640cc2a9b8983213d343ce954a8334d0a71c89b7 /nixos/modules/rename.nix
parentf673243aff0bc9ae4d2e96ccd60124ff9fe5b103 (diff)
downloadnixlib-1158eda66a7646ca8b8204ffbb3d1c55a73d0374.tar
nixlib-1158eda66a7646ca8b8204ffbb3d1c55a73d0374.tar.gz
nixlib-1158eda66a7646ca8b8204ffbb3d1c55a73d0374.tar.bz2
nixlib-1158eda66a7646ca8b8204ffbb3d1c55a73d0374.tar.lz
nixlib-1158eda66a7646ca8b8204ffbb3d1c55a73d0374.tar.xz
nixlib-1158eda66a7646ca8b8204ffbb3d1c55a73d0374.tar.zst
nixlib-1158eda66a7646ca8b8204ffbb3d1c55a73d0374.zip
dhcpd service: add DHCPv6 support
Diffstat (limited to 'nixos/modules/rename.nix')
-rw-r--r--nixos/modules/rename.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/nixos/modules/rename.nix b/nixos/modules/rename.nix
index 758f229d59d7..ad1ba86980d5 100644
--- a/nixos/modules/rename.nix
+++ b/nixos/modules/rename.nix
@@ -164,6 +164,9 @@ with lib;
         else { addr = value inetAddr; port = value inetPort; }
     ))
 
+    # dhcpd
+    (mkRenamedOptionModule [ "services" "dhcpd" ] [ "services" "dhcpd4" ])
+
     # Options that are obsolete and have no replacement.
     (mkRemovedOptionModule [ "boot" "initrd" "luks" "enable" ] "")
     (mkRemovedOptionModule [ "programs" "bash" "enable" ] "")