about summary refs log tree commit diff
path: root/nixos/modules/rename.nix
diff options
context:
space:
mode:
authorNikolay Amiantov <ab@fmap.me>2019-07-15 20:18:49 +0300
committerNikolay Amiantov <ab@fmap.me>2019-07-15 20:25:39 +0300
commit01b90dce78ee3906def0fc8d800217a3f9f40aa7 (patch)
treee4641a57c7dea1639d817fc97f4d22918dbd4ba5 /nixos/modules/rename.nix
parent267c8d6b2fea05bc811c8e2c2f4529b1436eeb9a (diff)
downloadnixlib-01b90dce78ee3906def0fc8d800217a3f9f40aa7.tar
nixlib-01b90dce78ee3906def0fc8d800217a3f9f40aa7.tar.gz
nixlib-01b90dce78ee3906def0fc8d800217a3f9f40aa7.tar.bz2
nixlib-01b90dce78ee3906def0fc8d800217a3f9f40aa7.tar.lz
nixlib-01b90dce78ee3906def0fc8d800217a3f9f40aa7.tar.xz
nixlib-01b90dce78ee3906def0fc8d800217a3f9f40aa7.tar.zst
nixlib-01b90dce78ee3906def0fc8d800217a3f9f40aa7.zip
resolvconf service: init
This is a refactor of how resolvconf is managed on NixOS. We split it
into a separate service which is enabled internally depending on whether
we want /etc/resolv.conf to be managed by it. Various services now take
advantage of those configuration options.

We also now use systemd instead of activation scripts to update
resolv.conf.

NetworkManager now uses the right option for rc-manager DNS
automatically, so the configuration option shouldn't be exposed.
Diffstat (limited to 'nixos/modules/rename.nix')
-rw-r--r--nixos/modules/rename.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/nixos/modules/rename.nix b/nixos/modules/rename.nix
index 1b77a895d717..ca8db9a1a48e 100644
--- a/nixos/modules/rename.nix
+++ b/nixos/modules/rename.nix
@@ -244,6 +244,12 @@ with lib;
     # KSM
     (mkRenamedOptionModule [ "hardware" "enableKSM" ] [ "hardware" "ksm" "enable" ])
 
+    # resolvconf
+    (mkRenamedOptionModule [ "networking" "dnsSingleRequest" ] [ "networking" "resolvconf" "dnsSingleRequest" ])
+    (mkRenamedOptionModule [ "networking" "dnsExtensionMechanism" ] [ "networking" "resolvconf" "dnsExtensionMechanism" ])
+    (mkRenamedOptionModule [ "networking" "extraResolvconfConf" ] [ "networking" "resolvconf" "extraConfig" ])
+    (mkRenamedOptionModule [ "networking" "resolvconfOptions" ] [ "networking" "resolvconf" "extraOptions" ])
+
   ] ++ (flip map [ "blackboxExporter" "collectdExporter" "fritzboxExporter"
                    "jsonExporter" "minioExporter" "nginxExporter" "nodeExporter"
                    "snmpExporter" "unifiExporter" "varnishExporter" ]