about summary refs log tree commit diff
path: root/nixos/modules/programs/xonsh.nix
diff options
context:
space:
mode:
authorRok Garbas <rok@garbas.si>2016-07-21 00:55:36 +0200
committerRok Garbas <rok@garbas.si>2016-07-21 00:55:36 +0200
commit760da3e3f39b43c113797456dcdbe8ad6cfb466c (patch)
treec26659da2c75cc75724044d19c17d6f3e5891af8 /nixos/modules/programs/xonsh.nix
parent15b2709365eab965b70102bc860146bc3bf06dc5 (diff)
downloadnixlib-760da3e3f39b43c113797456dcdbe8ad6cfb466c.tar
nixlib-760da3e3f39b43c113797456dcdbe8ad6cfb466c.tar.gz
nixlib-760da3e3f39b43c113797456dcdbe8ad6cfb466c.tar.bz2
nixlib-760da3e3f39b43c113797456dcdbe8ad6cfb466c.tar.lz
nixlib-760da3e3f39b43c113797456dcdbe8ad6cfb466c.tar.xz
nixlib-760da3e3f39b43c113797456dcdbe8ad6cfb466c.tar.zst
nixlib-760da3e3f39b43c113797456dcdbe8ad6cfb466c.zip
nixos: init programs.xonsh
Diffstat (limited to 'nixos/modules/programs/xonsh.nix')
-rw-r--r--nixos/modules/programs/xonsh.nix62
1 files changed, 62 insertions, 0 deletions
diff --git a/nixos/modules/programs/xonsh.nix b/nixos/modules/programs/xonsh.nix
new file mode 100644
index 000000000000..c0be2d8884b3
--- /dev/null
+++ b/nixos/modules/programs/xonsh.nix
@@ -0,0 +1,62 @@
+# This module defines global configuration for the xonsh.
+
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+let
+
+  cfge = config.environment;
+
+  cfg = config.programs.xonsh;
+
+in
+
+{
+
+  options = {
+
+    programs.xonsh = {
+
+      enable = mkOption {
+        default = false;
+        description = ''
+          Whether to configure xnosh as an interactive shell.
+        '';
+        type = types.bool;
+      };
+
+      package = mkOption {
+        type = types.package;
+        example = literalExample "pkgs.xonsh.override { configFile = \"/path/to/xonshrc\"; }";
+        description = ''
+          xonsh package to use.
+        '';
+      };
+
+      config = mkOption {
+        default = "";
+        description = "Control file to customize your shell behavior.";
+        type = types.lines;
+      };
+
+    };
+
+  };
+
+  config = mkIf cfg.enable {
+
+    environment.etc."xonshrc".text = cfg.config;
+
+    environment.systemPackages = [ pkgs.xonsh ];
+
+    environment.shells =
+      [ "/run/current-system/sw/bin/xonsh"
+        "/var/run/current-system/sw/bin/xonsh"
+        "${pkgs.xonsh}/bin/xonsh"
+      ];
+
+  };
+
+}
+