about summary refs log tree commit diff
path: root/nixos/modules/programs/ssmtp.nix
diff options
context:
space:
mode:
authorNikolay Amiantov <ab@fmap.me>2014-11-05 02:42:23 +0300
committerNikolay Amiantov <ab@fmap.me>2014-11-05 02:47:59 +0300
commit1b6f0ffb6e6e08bec48d8cf16bb8db719c1dfd79 (patch)
tree91791fb74d0fc4bad6a5083126eb71c9c0411911 /nixos/modules/programs/ssmtp.nix
parent292e07689a012b40945f71409441a5813eaede4c (diff)
downloadnixlib-1b6f0ffb6e6e08bec48d8cf16bb8db719c1dfd79.tar
nixlib-1b6f0ffb6e6e08bec48d8cf16bb8db719c1dfd79.tar.gz
nixlib-1b6f0ffb6e6e08bec48d8cf16bb8db719c1dfd79.tar.bz2
nixlib-1b6f0ffb6e6e08bec48d8cf16bb8db719c1dfd79.tar.lz
nixlib-1b6f0ffb6e6e08bec48d8cf16bb8db719c1dfd79.tar.xz
nixlib-1b6f0ffb6e6e08bec48d8cf16bb8db719c1dfd79.tar.zst
nixlib-1b6f0ffb6e6e08bec48d8cf16bb8db719c1dfd79.zip
ssmtp: add 'root' option
Diffstat (limited to 'nixos/modules/programs/ssmtp.nix')
-rw-r--r--nixos/modules/programs/ssmtp.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/nixos/modules/programs/ssmtp.nix b/nixos/modules/programs/ssmtp.nix
index a2cedb84321b..7b00efbb4686 100644
--- a/nixos/modules/programs/ssmtp.nix
+++ b/nixos/modules/programs/ssmtp.nix
@@ -44,6 +44,15 @@ in
         '';
       };
 
+      root = mkOption {
+        type = types.str;
+        default = "";
+        example = "root@example.org";
+        description = ''
+          The e-mail to which mail for users with UID &lt; 1000 is forwarded.
+        '';
+      };
+
       domain = mkOption {
         type = types.str;
         default = "";
@@ -103,6 +112,7 @@ in
       ''
         MailHub=${cfg.hostName}
         FromLineOverride=YES
+        ${if cfg.root != "" then "root=${cfg.root}" else ""}
         ${if cfg.domain != "" then "rewriteDomain=${cfg.domain}" else ""}
         UseTLS=${if cfg.useTLS then "YES" else "NO"}
         UseSTARTTLS=${if cfg.useSTARTTLS then "YES" else "NO"}