about summary refs log tree commit diff
path: root/nixos/modules/programs/nncp.nix
diff options
context:
space:
mode:
authorpennae <github@quasiparticle.net>2022-08-03 22:46:41 +0200
committerpennae <github@quasiparticle.net>2022-08-03 22:46:41 +0200
commit61e93df1891972bae3e0c97a477bd44e8a477aa0 (patch)
tree4285c1d22db537fb02baf1e978eb4434b0276b0c /nixos/modules/programs/nncp.nix
parent645cfa59ac5690187eac40ef2ac67381668acecc (diff)
downloadnixlib-61e93df1891972bae3e0c97a477bd44e8a477aa0.tar
nixlib-61e93df1891972bae3e0c97a477bd44e8a477aa0.tar.gz
nixlib-61e93df1891972bae3e0c97a477bd44e8a477aa0.tar.bz2
nixlib-61e93df1891972bae3e0c97a477bd44e8a477aa0.tar.lz
nixlib-61e93df1891972bae3e0c97a477bd44e8a477aa0.tar.xz
nixlib-61e93df1891972bae3e0c97a477bd44e8a477aa0.tar.zst
nixlib-61e93df1891972bae3e0c97a477bd44e8a477aa0.zip
nixos/*: automatically convert option docs to MD
once again using nix-doc-munge (https://github.com/pennae/nix-doc-munge/commit/69d080323ae27c0d8da3967c62b925a9aedb2828)
Diffstat (limited to 'nixos/modules/programs/nncp.nix')
-rw-r--r--nixos/modules/programs/nncp.nix18
1 files changed, 9 insertions, 9 deletions
diff --git a/nixos/modules/programs/nncp.nix b/nixos/modules/programs/nncp.nix
index f40e888dad8c..a58748d2fe62 100644
--- a/nixos/modules/programs/nncp.nix
+++ b/nixos/modules/programs/nncp.nix
@@ -33,24 +33,24 @@ in {
     secrets = mkOption {
       type = with types; listOf str;
       example = [ "/run/keys/nncp.hjson" ];
-      description = ''
+      description = lib.mdDoc ''
         A list of paths to NNCP configuration files that should not be
         in the Nix store. These files are layered on top of the values at
-        <xref linkend="opt-programs.nncp.settings"/>.
+        [](#opt-programs.nncp.settings).
       '';
     };
 
     settings = mkOption {
       type = settingsFormat.type;
-      description = ''
+      description = lib.mdDoc ''
         NNCP configuration, see
-        <link xlink:href="http://www.nncpgo.org/Configuration.html"/>.
+        <http://www.nncpgo.org/Configuration.html>.
         At runtime these settings will be overlayed by the contents of
-        <xref linkend="opt-programs.nncp.secrets"/> into the file
-        <literal>${nncpCfgFile}</literal>. Node keypairs go in
-        <literal>secrets</literal>, do not specify them in
-        <literal>settings</literal> as they will be leaked into
-        <literal>/nix/store</literal>!
+        [](#opt-programs.nncp.secrets) into the file
+        `${nncpCfgFile}`. Node keypairs go in
+        `secrets`, do not specify them in
+        `settings` as they will be leaked into
+        `/nix/store`!
       '';
       default = { };
     };