about summary refs log tree commit diff
path: root/nixos/modules/programs/mtr.nix
diff options
context:
space:
mode:
authorPeter Hoeg <peter@hoeg.com>2017-09-14 19:05:11 +0800
committerPeter Hoeg <peter@hoeg.com>2017-09-14 19:09:54 +0800
commit4b78d44ab6a4c9d8f7b5c719985851f4a636b6ea (patch)
treefa08f2d390413242a64d492539ef66623d55d629 /nixos/modules/programs/mtr.nix
parentd29a8f25c3fc5601c7c4250868e4900a91dd55cb (diff)
downloadnixlib-4b78d44ab6a4c9d8f7b5c719985851f4a636b6ea.tar
nixlib-4b78d44ab6a4c9d8f7b5c719985851f4a636b6ea.tar.gz
nixlib-4b78d44ab6a4c9d8f7b5c719985851f4a636b6ea.tar.bz2
nixlib-4b78d44ab6a4c9d8f7b5c719985851f4a636b6ea.tar.lz
nixlib-4b78d44ab6a4c9d8f7b5c719985851f4a636b6ea.tar.xz
nixlib-4b78d44ab6a4c9d8f7b5c719985851f4a636b6ea.tar.zst
nixlib-4b78d44ab6a4c9d8f7b5c719985851f4a636b6ea.zip
mtr nixos module: wrap the proper binary
Diffstat (limited to 'nixos/modules/programs/mtr.nix')
-rw-r--r--nixos/modules/programs/mtr.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/nixos/modules/programs/mtr.nix b/nixos/modules/programs/mtr.nix
index 927fe68be875..1fdec4c04f68 100644
--- a/nixos/modules/programs/mtr.nix
+++ b/nixos/modules/programs/mtr.nix
@@ -19,8 +19,9 @@ in {
   };
 
   config = mkIf cfg.enable {
-    security.wrappers.mtr = {
-      source = "${pkgs.mtr}/bin/mtr";
+    environment.systemPackages = with pkgs; [ mtr ];
+    security.wrappers.mtr-packet = {
+      source = "${pkgs.mtr}/bin/mtr-packet";
       capabilities = "cap_net_raw+p";
     };
   };