about summary refs log tree commit diff
path: root/nixos/modules/programs/less.nix
diff options
context:
space:
mode:
authorpennae <github@quasiparticle.net>2022-07-20 12:32:04 +0200
committerpennae <github@quasiparticle.net>2022-07-24 13:01:18 +0200
commitda37ca6760983e9c95f6e2945e31f7e78fb83da5 (patch)
tree63edbe78bd96b8bcf2139f51bff80861f8796960 /nixos/modules/programs/less.nix
parent4f9183858429fba967a92519e6c63e3310a78ee5 (diff)
downloadnixlib-da37ca6760983e9c95f6e2945e31f7e78fb83da5.tar
nixlib-da37ca6760983e9c95f6e2945e31f7e78fb83da5.tar.gz
nixlib-da37ca6760983e9c95f6e2945e31f7e78fb83da5.tar.bz2
nixlib-da37ca6760983e9c95f6e2945e31f7e78fb83da5.tar.lz
nixlib-da37ca6760983e9c95f6e2945e31f7e78fb83da5.tar.xz
nixlib-da37ca6760983e9c95f6e2945e31f7e78fb83da5.tar.zst
nixlib-da37ca6760983e9c95f6e2945e31f7e78fb83da5.zip
nixos/programs: invariant option docs MD conversions
Diffstat (limited to 'nixos/modules/programs/less.nix')
-rw-r--r--nixos/modules/programs/less.nix20
1 files changed, 10 insertions, 10 deletions
diff --git a/nixos/modules/programs/less.nix b/nixos/modules/programs/less.nix
index 794146b19faf..9f2d5d915815 100644
--- a/nixos/modules/programs/less.nix
+++ b/nixos/modules/programs/less.nix
@@ -41,12 +41,12 @@ in
         type = types.nullOr types.path;
         default = null;
         example = literalExpression ''"''${pkgs.my-configs}/lesskey"'';
-        description = ''
+        description = lib.mdDoc ''
           Path to lesskey configuration file.
 
-          <option>configFile</option> takes precedence over <option>commands</option>,
-          <option>clearDefaultCommands</option>, <option>lineEditingKeys</option>, and
-          <option>envVariables</option>.
+          {option}`configFile` takes precedence over {option}`commands`,
+          {option}`clearDefaultCommands`, {option}`lineEditingKeys`, and
+          {option}`envVariables`.
         '';
       };
 
@@ -57,13 +57,13 @@ in
           h = "noaction 5\\e(";
           l = "noaction 5\\e)";
         };
-        description = "Defines new command keys.";
+        description = lib.mdDoc "Defines new command keys.";
       };
 
       clearDefaultCommands = mkOption {
         type = types.bool;
         default = false;
-        description = ''
+        description = lib.mdDoc ''
           Clear all default commands.
           You should remember to set the quit key.
           Otherwise you will not be able to leave less without killing it.
@@ -76,7 +76,7 @@ in
         example = {
           e = "abort";
         };
-        description = "Defines new line-editing keys.";
+        description = lib.mdDoc "Defines new line-editing keys.";
       };
 
       envVariables = mkOption {
@@ -87,14 +87,14 @@ in
         example = {
           LESS = "--quit-if-one-screen";
         };
-        description = "Defines environment variables.";
+        description = lib.mdDoc "Defines environment variables.";
       };
 
       lessopen = mkOption {
         type = types.nullOr types.str;
         default = "|${pkgs.lesspipe}/bin/lesspipe.sh %s";
         defaultText = literalExpression ''"|''${pkgs.lesspipe}/bin/lesspipe.sh %s"'';
-        description = ''
+        description = lib.mdDoc ''
           Before less opens a file, it first gives your input preprocessor a chance to modify the way the contents of the file are displayed.
         '';
       };
@@ -102,7 +102,7 @@ in
       lessclose = mkOption {
         type = types.nullOr types.str;
         default = null;
-        description = ''
+        description = lib.mdDoc ''
           When less closes a file opened in such a way, it will call another program, called the input postprocessor, which may  perform  any  desired  clean-up  action (such  as deleting the replacement file created by LESSOPEN).
         '';
       };