about summary refs log tree commit diff
path: root/nixos/modules/programs/gnupg.nix
diff options
context:
space:
mode:
authorHeitham Omar <hhomar@gmail.com>2018-10-21 10:19:04 +0100
committerHeitham Omar <hhomar@gmail.com>2018-10-21 10:19:04 +0100
commit433ea7bf3a7bebe465f703c0d1b4d8abe69cb998 (patch)
treeecb9f4aca6716246fe4a66a63e7048262bf68cae /nixos/modules/programs/gnupg.nix
parent7a10601dc4f818ecc24097ac8ab38e2e0050cf1d (diff)
downloadnixlib-433ea7bf3a7bebe465f703c0d1b4d8abe69cb998.tar
nixlib-433ea7bf3a7bebe465f703c0d1b4d8abe69cb998.tar.gz
nixlib-433ea7bf3a7bebe465f703c0d1b4d8abe69cb998.tar.bz2
nixlib-433ea7bf3a7bebe465f703c0d1b4d8abe69cb998.tar.lz
nixlib-433ea7bf3a7bebe465f703c0d1b4d8abe69cb998.tar.xz
nixlib-433ea7bf3a7bebe465f703c0d1b4d8abe69cb998.tar.zst
nixlib-433ea7bf3a7bebe465f703c0d1b4d8abe69cb998.zip
gnupg: Fix, set current tty in interactive shell
GPG_TTY was not being set to the current tty, breaking pinentry-tty/pinentry-curses.
Diffstat (limited to 'nixos/modules/programs/gnupg.nix')
-rw-r--r--nixos/modules/programs/gnupg.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/programs/gnupg.nix b/nixos/modules/programs/gnupg.nix
index addc9dcca87e..b01de9efaa5e 100644
--- a/nixos/modules/programs/gnupg.nix
+++ b/nixos/modules/programs/gnupg.nix
@@ -77,7 +77,7 @@ in
 
     systemd.packages = [ pkgs.gnupg ];
 
-    environment.extraInit = ''
+    environment.interactiveShellInit = ''
       # Bind gpg-agent to this TTY if gpg commands are used.
       export GPG_TTY=$(tty)