about summary refs log tree commit diff
path: root/nixos/modules/programs/git.nix
diff options
context:
space:
mode:
authorfigsoda <figsoda@pm.me>2021-10-13 15:17:42 -0400
committerfigsoda <figsoda@pm.me>2021-10-16 22:39:56 -0400
commit471cfaf523dfcd89ce6d91717f2fee47eb29504e (patch)
tree2998730e7a514b59d1b47074c376e0be8cf649be /nixos/modules/programs/git.nix
parenta6bff35d96b893f3b4ba378c7af086901493ae3a (diff)
downloadnixlib-471cfaf523dfcd89ce6d91717f2fee47eb29504e.tar
nixlib-471cfaf523dfcd89ce6d91717f2fee47eb29504e.tar.gz
nixlib-471cfaf523dfcd89ce6d91717f2fee47eb29504e.tar.bz2
nixlib-471cfaf523dfcd89ce6d91717f2fee47eb29504e.tar.lz
nixlib-471cfaf523dfcd89ce6d91717f2fee47eb29504e.tar.xz
nixlib-471cfaf523dfcd89ce6d91717f2fee47eb29504e.tar.zst
nixlib-471cfaf523dfcd89ce6d91717f2fee47eb29504e.zip
nixos/git: change config type
Diffstat (limited to 'nixos/modules/programs/git.nix')
-rw-r--r--nixos/modules/programs/git.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/programs/git.nix b/nixos/modules/programs/git.nix
index 6c60daf21f9f..06ce374b1992 100644
--- a/nixos/modules/programs/git.nix
+++ b/nixos/modules/programs/git.nix
@@ -20,7 +20,7 @@ in
       };
 
       config = mkOption {
-        type = types.attrs;
+        type = with types; attrsOf (attrsOf anything);
         default = { };
         example = {
           init.defaultBranch = "main";