about summary refs log tree commit diff
path: root/nixos/modules/programs/flashrom.nix
diff options
context:
space:
mode:
authorR-VdP <141248+R-VdP@users.noreply.github.com>2023-02-17 15:56:51 +0100
committerR-VdP <141248+R-VdP@users.noreply.github.com>2023-02-17 15:56:51 +0100
commit8467c637493595a2023a1285100c7636c89f9217 (patch)
tree2f189b58c7bcd0869e3cb6e4f0b57e488c19d12f /nixos/modules/programs/flashrom.nix
parent835425849185b3ca120c6abd5f1bdd6ff9f3f9f9 (diff)
downloadnixlib-8467c637493595a2023a1285100c7636c89f9217.tar
nixlib-8467c637493595a2023a1285100c7636c89f9217.tar.gz
nixlib-8467c637493595a2023a1285100c7636c89f9217.tar.bz2
nixlib-8467c637493595a2023a1285100c7636c89f9217.tar.lz
nixlib-8467c637493595a2023a1285100c7636c89f9217.tar.xz
nixlib-8467c637493595a2023a1285100c7636c89f9217.tar.zst
nixlib-8467c637493595a2023a1285100c7636c89f9217.zip
flashrom: use a udev uaccess tag instead of introducing a custom flashrom group
See https://wiki.archlinux.org/title/Udev#Allowing_regular_users_to_use_devices for more info about the uaccess tag. The udev-acl tag is a legacy implementation, we add it purely for backwards compatibility.
Diffstat (limited to 'nixos/modules/programs/flashrom.nix')
-rw-r--r--nixos/modules/programs/flashrom.nix1
1 files changed, 0 insertions, 1 deletions
diff --git a/nixos/modules/programs/flashrom.nix b/nixos/modules/programs/flashrom.nix
index 294b208a3720..9f8faff14e47 100644
--- a/nixos/modules/programs/flashrom.nix
+++ b/nixos/modules/programs/flashrom.nix
@@ -22,6 +22,5 @@ in
   config = mkIf cfg.enable {
     services.udev.packages = [ cfg.package ];
     environment.systemPackages = [ cfg.package ];
-    users.groups.flashrom = { };
   };
 }