about summary refs log tree commit diff
path: root/nixos/modules/programs/_1password-gui.nix
diff options
context:
space:
mode:
authormidchildan <git@midchildan.org>2022-05-08 19:48:29 +0900
committermidchildan <git@midchildan.org>2022-05-15 22:15:11 +0900
commit2a58907251af76c67c6d14c1e84e73f7eaeb95e8 (patch)
treedb87614ad6b1017a25f76ebb889449009c9eb1d4 /nixos/modules/programs/_1password-gui.nix
parent3c8e6248cbb4b400c1b2b79d523e4b02b9a7ca40 (diff)
downloadnixlib-2a58907251af76c67c6d14c1e84e73f7eaeb95e8.tar
nixlib-2a58907251af76c67c6d14c1e84e73f7eaeb95e8.tar.gz
nixlib-2a58907251af76c67c6d14c1e84e73f7eaeb95e8.tar.bz2
nixlib-2a58907251af76c67c6d14c1e84e73f7eaeb95e8.tar.lz
nixlib-2a58907251af76c67c6d14c1e84e73f7eaeb95e8.tar.xz
nixlib-2a58907251af76c67c6d14c1e84e73f7eaeb95e8.tar.zst
nixlib-2a58907251af76c67c6d14c1e84e73f7eaeb95e8.zip
nixos/_1password{,-gui}: use a static gid
Diffstat (limited to 'nixos/modules/programs/_1password-gui.nix')
-rw-r--r--nixos/modules/programs/_1password-gui.nix17
1 files changed, 7 insertions, 10 deletions
diff --git a/nixos/modules/programs/_1password-gui.nix b/nixos/modules/programs/_1password-gui.nix
index 42f6a0b52252..657116c267d9 100644
--- a/nixos/modules/programs/_1password-gui.nix
+++ b/nixos/modules/programs/_1password-gui.nix
@@ -8,19 +8,16 @@ let
 
 in
 {
+  imports = [
+    (mkRemovedOptionModule [ "programs" "_1password-gui" "gid" ] ''
+      A preallocated GID will be used instead.
+    '')
+  ];
+
   options = {
     programs._1password-gui = {
       enable = mkEnableOption "the 1Password GUI application";
 
-      gid = mkOption {
-        type = types.addCheck types.int (x: x >= 1000);
-        example = literalExpression "5000";
-        description = ''
-          The gid to assign to the onepassword group, which is needed for browser integration.
-          It must be 1000 or greater.
-        '';
-      };
-
       polkitPolicyOwners = mkOption {
         type = types.listOf types.str;
         default = [ ];
@@ -44,7 +41,7 @@ in
     in
     mkIf cfg.enable {
       environment.systemPackages = [ package ];
-      users.groups.onepassword.gid = cfg.gid;
+      users.groups.onepassword.gid = config.ids.gids.onepassword;
 
       security.wrappers = {
         "1Password-BrowserSupport" = {