about summary refs log tree commit diff
path: root/nixos/modules/profiles/docker-container.nix
diff options
context:
space:
mode:
authorMichael Bishop <cleverca22@gmail.com>2018-03-17 21:26:42 -0300
committerMichael Bishop <cleverca22@gmail.com>2018-04-03 11:30:43 -0300
commit3c9e579d1ebdca423766983c3e8fec7ba56407c3 (patch)
tree8ef5d66e1fe48c448d894d648684ec86a7b725a2 /nixos/modules/profiles/docker-container.nix
parent26db7314c85962ac241944a118033f6e8e5ccf4c (diff)
downloadnixlib-3c9e579d1ebdca423766983c3e8fec7ba56407c3.tar
nixlib-3c9e579d1ebdca423766983c3e8fec7ba56407c3.tar.gz
nixlib-3c9e579d1ebdca423766983c3e8fec7ba56407c3.tar.bz2
nixlib-3c9e579d1ebdca423766983c3e8fec7ba56407c3.tar.lz
nixlib-3c9e579d1ebdca423766983c3e8fec7ba56407c3.tar.xz
nixlib-3c9e579d1ebdca423766983c3e8fec7ba56407c3.tar.zst
nixlib-3c9e579d1ebdca423766983c3e8fec7ba56407c3.zip
make-system-tarball: allow alternate compression methods
Diffstat (limited to 'nixos/modules/profiles/docker-container.nix')
-rw-r--r--nixos/modules/profiles/docker-container.nix4
1 files changed, 1 insertions, 3 deletions
diff --git a/nixos/modules/profiles/docker-container.nix b/nixos/modules/profiles/docker-container.nix
index 433492b96137..7031d7d1d593 100644
--- a/nixos/modules/profiles/docker-container.nix
+++ b/nixos/modules/profiles/docker-container.nix
@@ -14,9 +14,7 @@ in {
   ];
 
   # Create the tarball
-  system.build.tarball = import ../../lib/make-system-tarball.nix {
-    inherit (pkgs) stdenv perl xz pathsFromGraph;
-
+  system.build.tarball = pkgs.callPackage ../../lib/make-system-tarball.nix {
     contents = [];
     extraArgs = "--owner=0";