about summary refs log tree commit diff
path: root/nixos/modules/module-list.nix
diff options
context:
space:
mode:
authorbaroncharlus <elliot@ellioteverettwright.com>2018-05-16 08:16:30 -0500
committerxeji <36407913+xeji@users.noreply.github.com>2018-05-16 15:16:30 +0200
commit380cdd8dd71398721909cd7560f8d0ded44abe21 (patch)
treee2740310f877876ee5cbfe92b0dba9c4f398cc01 /nixos/modules/module-list.nix
parent727216217962f7d14e83cccb32e4549486d9075d (diff)
downloadnixlib-380cdd8dd71398721909cd7560f8d0ded44abe21.tar
nixlib-380cdd8dd71398721909cd7560f8d0ded44abe21.tar.gz
nixlib-380cdd8dd71398721909cd7560f8d0ded44abe21.tar.bz2
nixlib-380cdd8dd71398721909cd7560f8d0ded44abe21.tar.lz
nixlib-380cdd8dd71398721909cd7560f8d0ded44abe21.tar.xz
nixlib-380cdd8dd71398721909cd7560f8d0ded44abe21.tar.zst
nixlib-380cdd8dd71398721909cd7560f8d0ded44abe21.zip
Add stubby resolver daemon service module (#38667)
* networking/stubby.nix: implementing systemd service module for stubby

This change implements stubby, the DNS-over-TLS stub resolver daemon.
The motivation for this change was the desire to use stubby's
DNS-over-TLS funcitonality in tandem with unbound, which requires
passing certain configuration parameters. This module implements those
config parameters by exposing them for use in configuration.nix.

* networking/stubby.nix: merging back module list

re-merging the module list to remove unecessary changes.

* networking/stubby.nix: removing unecessary capabilities flag

This change removes the unecessary flag for toggling the capabilities
which allows the daemon to bind to low ports.

* networking/stubby.nix: adding debug level logging bool

Adding the option to turn on debug logging.

* networking/stubby.nix: clarifying idleTimeout and adding systemd target

Improving docs to note that idleTimeout is expressed in ms. Adding the
nss-lookup `before' target to the systemd service definition.

* networking/stubby.nix: Restrict options with types.enum

This change restricts fallbackProtocol and authenticationMode to accept
only valid options instead of any list or str types (respectively). This
change also fixes typo in the CapabilityBoundingSet systemd setting.

* networking/stubby.nix: cleaning up documentation

Cleaning up docs, adding literal tags to settings, and removing
whitespace.

* networking/stubby.nix: fixing missing linebreak in comments

* networking/stubby.nix: cleaning errant comments
Diffstat (limited to 'nixos/modules/module-list.nix')
-rw-r--r--nixos/modules/module-list.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/nixos/modules/module-list.nix b/nixos/modules/module-list.nix
index 8ce29e52fb24..7bce8e44eccd 100644
--- a/nixos/modules/module-list.nix
+++ b/nixos/modules/module-list.nix
@@ -569,6 +569,7 @@
   ./services/networking/strongswan.nix
   ./services/networking/strongswan-swanctl/module.nix
   ./services/networking/stunnel.nix
+  ./services/networking/stubby.nix
   ./services/networking/supplicant.nix
   ./services/networking/supybot.nix
   ./services/networking/syncthing.nix