about summary refs log tree commit diff
path: root/nixos/modules/misc/lib.nix
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2014-05-05 14:58:51 -0400
committerShea Levy <shea@shealevy.com>2014-07-02 12:28:18 -0400
commitb3cfb9084b3860852581be235aea90540a5302d4 (patch)
tree06cf1333ae7d60f25bd23866dbaec17b148a15dd /nixos/modules/misc/lib.nix
parent80709b141ca82d5afe3874f50b822db3409bed4e (diff)
downloadnixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar.gz
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar.bz2
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar.lz
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar.xz
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar.zst
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.zip
Get all lib functions from lib, not pkgs.lib, in modules
Diffstat (limited to 'nixos/modules/misc/lib.nix')
-rw-r--r--nixos/modules/misc/lib.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/nixos/modules/misc/lib.nix b/nixos/modules/misc/lib.nix
index 18fc68a69883..be8000ac029d 100644
--- a/nixos/modules/misc/lib.nix
+++ b/nixos/modules/misc/lib.nix
@@ -1,11 +1,11 @@
-{ config, pkgs, ... }:
+{ config, lib, ... }:
 
 {
   options = {
-    lib = pkgs.lib.mkOption {
+    lib = lib.mkOption {
       default = {};
 
-      type = pkgs.lib.types.attrsOf pkgs.lib.types.attrs;
+      type = lib.types.attrsOf lib.types.attrs;
 
       description = ''
         This option allows modules to define helper functions, constants, etc.