about summary refs log tree commit diff
path: root/nixos/modules/installer/tools/tools.nix
diff options
context:
space:
mode:
authorvolth <volth@webmaster.ms>2019-04-25 12:08:20 +0000
committerGitHub <noreply@github.com>2019-04-25 12:08:20 +0000
commitc01ea27ce356e1433da01a7b46ba40c880f2f2ac (patch)
tree6c90b701ea2a042de6d8fde386b0a3dd45587088 /nixos/modules/installer/tools/tools.nix
parent5d2775156b5fe781895528ffa08513a22822127d (diff)
downloadnixlib-c01ea27ce356e1433da01a7b46ba40c880f2f2ac.tar
nixlib-c01ea27ce356e1433da01a7b46ba40c880f2f2ac.tar.gz
nixlib-c01ea27ce356e1433da01a7b46ba40c880f2f2ac.tar.bz2
nixlib-c01ea27ce356e1433da01a7b46ba40c880f2f2ac.tar.lz
nixlib-c01ea27ce356e1433da01a7b46ba40c880f2f2ac.tar.xz
nixlib-c01ea27ce356e1433da01a7b46ba40c880f2f2ac.tar.zst
nixlib-c01ea27ce356e1433da01a7b46ba40c880f2f2ac.zip
nixos-generate-config: do not build btrfs-tools when btrfs is not used
cross-compilation of `btrfs-tools` is broken, and this usually needless dependency of each system closure on `btrfs-tools` prevents cross-compilation of whole system closures
Diffstat (limited to 'nixos/modules/installer/tools/tools.nix')
-rw-r--r--nixos/modules/installer/tools/tools.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/installer/tools/tools.nix b/nixos/modules/installer/tools/tools.nix
index 00c4d5018bf5..59eb4a63af40 100644
--- a/nixos/modules/installer/tools/tools.nix
+++ b/nixos/modules/installer/tools/tools.nix
@@ -36,7 +36,7 @@ let
   nixos-generate-config = makeProg {
     name = "nixos-generate-config";
     src = ./nixos-generate-config.pl;
-    path = [ pkgs.btrfs-progs ];
+    path = lib.optionals (lib.elem "btrfs" config.boot.supportedFilesystems) [ pkgs.btrfs-progs ];
     perl = "${pkgs.perl}/bin/perl -I${pkgs.perlPackages.FileSlurp}/${pkgs.perl.libPrefix}";
     inherit (config.system.nixos) release;
   };