about summary refs log tree commit diff
path: root/nixos/modules/installer/cd-dvd/sd-image.nix
diff options
context:
space:
mode:
authorColin L Rice <colin@daedrum.net>2019-11-03 19:25:26 -0500
committerColin L Rice <colin@daedrum.net>2019-11-05 10:10:51 -0500
commitc861f8083d96eac4593796e65f8197908ebcbbc1 (patch)
treeb3a4a17cbc1a5719b966e228be8f39605790720f /nixos/modules/installer/cd-dvd/sd-image.nix
parent1c4b13bb5b248f4760e1ef2dae68a54a70dbeb39 (diff)
downloadnixlib-c861f8083d96eac4593796e65f8197908ebcbbc1.tar
nixlib-c861f8083d96eac4593796e65f8197908ebcbbc1.tar.gz
nixlib-c861f8083d96eac4593796e65f8197908ebcbbc1.tar.bz2
nixlib-c861f8083d96eac4593796e65f8197908ebcbbc1.tar.lz
nixlib-c861f8083d96eac4593796e65f8197908ebcbbc1.tar.xz
nixlib-c861f8083d96eac4593796e65f8197908ebcbbc1.tar.zst
nixlib-c861f8083d96eac4593796e65f8197908ebcbbc1.zip
sd-image: Add the compressed file path for hydra.
This makes the nixos on arm user instructions work again.
Diffstat (limited to 'nixos/modules/installer/cd-dvd/sd-image.nix')
-rw-r--r--nixos/modules/installer/cd-dvd/sd-image.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/nixos/modules/installer/cd-dvd/sd-image.nix b/nixos/modules/installer/cd-dvd/sd-image.nix
index d510f3b2daf2..7865b767f0b7 100644
--- a/nixos/modules/installer/cd-dvd/sd-image.nix
+++ b/nixos/modules/installer/cd-dvd/sd-image.nix
@@ -140,7 +140,11 @@ in
         export img=$out/sd-image/${config.sdImage.imageName}
 
         echo "${pkgs.stdenv.buildPlatform.system}" > $out/nix-support/system
-        echo "file sd-image $img" >> $out/nix-support/hydra-build-products
+        if test -n "$compressImage"; then
+          echo "file sd-image $img.bz2" >> $out/nix-support/hydra-build-products
+        else
+          echo "file sd-image $img" >> $out/nix-support/hydra-build-products
+        fi
 
         # Gap in front of the first partition, in MiB
         gap=8