about summary refs log tree commit diff
path: root/nixos/modules/image/repart-image.nix
diff options
context:
space:
mode:
authorWilliButz <willibutz@posteo.de>2024-03-07 18:24:00 +0100
committerWilliButz <willibutz@posteo.de>2024-03-07 22:50:56 +0100
commit82ef47d3b71c54fdb8449a7a8919a81685572a52 (patch)
tree6d6a2c18a011b876f9c3c7a60364aae6b0ea853e /nixos/modules/image/repart-image.nix
parentf88148f05e28015dbd01d49bc8c22ff11b3db052 (diff)
downloadnixlib-82ef47d3b71c54fdb8449a7a8919a81685572a52.tar
nixlib-82ef47d3b71c54fdb8449a7a8919a81685572a52.tar.gz
nixlib-82ef47d3b71c54fdb8449a7a8919a81685572a52.tar.bz2
nixlib-82ef47d3b71c54fdb8449a7a8919a81685572a52.tar.lz
nixlib-82ef47d3b71c54fdb8449a7a8919a81685572a52.tar.xz
nixlib-82ef47d3b71c54fdb8449a7a8919a81685572a52.tar.zst
nixlib-82ef47d3b71c54fdb8449a7a8919a81685572a52.zip
nixos/repart-image: add options to specify mkfs parameters
This new option makes it easier to specify extra mkfs parameters for the
systemd-repart builder.

See https://github.com/systemd/systemd/blob/v255/docs/ENVIRONMENT.md?plain=1#L575-L577
Diffstat (limited to 'nixos/modules/image/repart-image.nix')
-rw-r--r--nixos/modules/image/repart-image.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/nixos/modules/image/repart-image.nix b/nixos/modules/image/repart-image.nix
index 56f2775636a8..5ae523c43f58 100644
--- a/nixos/modules/image/repart-image.nix
+++ b/nixos/modules/image/repart-image.nix
@@ -34,6 +34,7 @@
 , seed
 , definitionsDirectory
 , sectorSize
+, mkfsEnv ? {}
 }:
 
 let
@@ -89,6 +90,8 @@ runCommand imageFileBasename
     compressionPkg
   ] ++ fileSystemTools;
 
+  env = mkfsEnv;
+
   systemdRepartFlags = [
     "--dry-run=no"
     "--empty=create"