about summary refs log tree commit diff
path: root/nixos/modules/hardware/video/uvcvideo/default.nix
diff options
context:
space:
mode:
authorRaymond Gauthier <jraygauthier@gmail.com>2018-06-09 01:59:21 -0400
committerRaymond Gauthier <jraygauthier@gmail.com>2018-06-11 11:33:49 -0400
commit3dfc9cd8268b10e990a7e9af536dbc7b12099789 (patch)
tree6ebf4dc8a2bf78d0ad654d2ccedc8b9abf03a124 /nixos/modules/hardware/video/uvcvideo/default.nix
parent5d960b51c66f7dff154a9ddda76296269bf922ee (diff)
downloadnixlib-3dfc9cd8268b10e990a7e9af536dbc7b12099789.tar
nixlib-3dfc9cd8268b10e990a7e9af536dbc7b12099789.tar.gz
nixlib-3dfc9cd8268b10e990a7e9af536dbc7b12099789.tar.bz2
nixlib-3dfc9cd8268b10e990a7e9af536dbc7b12099789.tar.lz
nixlib-3dfc9cd8268b10e990a7e9af536dbc7b12099789.tar.xz
nixlib-3dfc9cd8268b10e990a7e9af536dbc7b12099789.tar.zst
nixlib-3dfc9cd8268b10e990a7e9af536dbc7b12099789.zip
nixos/uvcvideo.dynctrl: Init
Diffstat (limited to 'nixos/modules/hardware/video/uvcvideo/default.nix')
-rw-r--r--nixos/modules/hardware/video/uvcvideo/default.nix64
1 files changed, 64 insertions, 0 deletions
diff --git a/nixos/modules/hardware/video/uvcvideo/default.nix b/nixos/modules/hardware/video/uvcvideo/default.nix
new file mode 100644
index 000000000000..7e3e94fdf2bd
--- /dev/null
+++ b/nixos/modules/hardware/video/uvcvideo/default.nix
@@ -0,0 +1,64 @@
+
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+let
+
+  cfg = config.services.uvcvideo;
+
+  uvcdynctrl-udev-rules = packages: pkgs.callPackage ./uvcdynctrl-udev-rules.nix {
+    drivers = packages;
+    udevDebug = false;
+  };
+
+in
+
+{
+
+  options = {
+    services.uvcvideo.dynctrl = {
+
+      enable = mkOption {
+        type = types.bool;
+        default = false;
+        description = ''
+          Whether to enable <command>uvcvideo</command> dynamic controls.
+
+          Note that enabling this brings the <command>uvcdynctrl</command> tool
+          into your environement and register all dynamic controls from
+          specified <command>packages</command> to the <command>uvcvideo</command> driver.
+        '';
+      };
+
+      packages = mkOption {
+        type = types.listOf types.path;
+        example = literalExample "[ pkgs.tiscamera ]";
+        description = ''
+          List of packages containing <command>uvcvideo</command> dynamic controls
+          rules. All files found in
+          <filename><replaceable>pkg</replaceable>/share/uvcdynctrl/data</filename>
+          will be included.
+
+          Note that these will serve as input to the <command>libwebcam</command>
+          package which through its own <command>udev</command> rule will register
+          the dynamic controls from specified packages to the <command>uvcvideo</command>
+          driver.
+        '';
+        apply = map getBin;
+      };
+    };
+  };
+
+  config = mkIf cfg.dynctrl.enable {
+
+    services.udev.packages = [
+      (uvcdynctrl-udev-rules cfg.dynctrl.packages)
+    ];
+
+    environment.systemPackages = [
+      pkgs.libwebcam
+    ];
+
+  };
+}