about summary refs log tree commit diff
path: root/nixos/modules/config/zram.nix
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@nextrem.ch>2022-09-02 08:23:20 +0200
committerGitHub <noreply@github.com>2022-09-02 08:23:20 +0200
commite18ee6fb2fd9426b7a77c65fa8a0a91955660aac (patch)
treefd269379dbe3c456221713d3d8f5378b0d1a5df1 /nixos/modules/config/zram.nix
parentce7352990d45da4ed44ca7f0e03b9751620210fe (diff)
parent23264904d8b275ee00b7b6a724ca541ecf35e5e3 (diff)
downloadnixlib-e18ee6fb2fd9426b7a77c65fa8a0a91955660aac.tar
nixlib-e18ee6fb2fd9426b7a77c65fa8a0a91955660aac.tar.gz
nixlib-e18ee6fb2fd9426b7a77c65fa8a0a91955660aac.tar.bz2
nixlib-e18ee6fb2fd9426b7a77c65fa8a0a91955660aac.tar.lz
nixlib-e18ee6fb2fd9426b7a77c65fa8a0a91955660aac.tar.xz
nixlib-e18ee6fb2fd9426b7a77c65fa8a0a91955660aac.tar.zst
nixlib-e18ee6fb2fd9426b7a77c65fa8a0a91955660aac.zip
Merge pull request #189111 from rapenne-s/zram_doc
zram module: rewording documentation to avoid misconception
Diffstat (limited to 'nixos/modules/config/zram.nix')
-rw-r--r--nixos/modules/config/zram.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/nixos/modules/config/zram.nix b/nixos/modules/config/zram.nix
index b162fbc311e3..cc2ca6314433 100644
--- a/nixos/modules/config/zram.nix
+++ b/nixos/modules/config/zram.nix
@@ -73,10 +73,10 @@ in
         default = 50;
         type = types.int;
         description = lib.mdDoc ''
-          Maximum amount of memory that can be used by the zram swap devices
+          Maximum total amount of memory that can be stored in the zram swap devices
           (as a percentage of your total memory). Defaults to 1/2 of your total
-          RAM. Run `zramctl` to check how good memory is
-          compressed.
+          RAM. Run `zramctl` to check how good memory is compressed.
+          This doesn't define how much memory will be used by the zram swap devices.
         '';
       };
 
@@ -84,8 +84,9 @@ in
         default = null;
         type = with types; nullOr int;
         description = lib.mdDoc ''
-          Maximum total amount of memory (in bytes) that can be used by the zram
+          Maximum total amount of memory (in bytes) that can be stored in the zram
           swap devices.
+          This doesn't define how much memory will be used by the zram swap devices.
         '';
       };