about summary refs log tree commit diff
path: root/nixos/modules/config/zram.nix
diff options
context:
space:
mode:
authorpennae <github@quasiparticle.net>2022-08-15 07:16:25 +0200
committerpennae <82953136+pennae@users.noreply.github.com>2022-08-19 22:40:58 +0200
commit6039648c50c7c0858b5e506c6298773a98e0f066 (patch)
tree5421b3c36609e710c85b43d92dc3b830f6a1385b /nixos/modules/config/zram.nix
parent7e7d68a250f75678451cd44f8c3d585bf750461e (diff)
downloadnixlib-6039648c50c7c0858b5e506c6298773a98e0f066.tar
nixlib-6039648c50c7c0858b5e506c6298773a98e0f066.tar.gz
nixlib-6039648c50c7c0858b5e506c6298773a98e0f066.tar.bz2
nixlib-6039648c50c7c0858b5e506c6298773a98e0f066.tar.lz
nixlib-6039648c50c7c0858b5e506c6298773a98e0f066.tar.xz
nixlib-6039648c50c7c0858b5e506c6298773a98e0f066.tar.zst
nixlib-6039648c50c7c0858b5e506c6298773a98e0f066.zip
nixos/*: automatically convert option docs
Diffstat (limited to 'nixos/modules/config/zram.nix')
-rw-r--r--nixos/modules/config/zram.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/nixos/modules/config/zram.nix b/nixos/modules/config/zram.nix
index e8e3fff01e08..b162fbc311e3 100644
--- a/nixos/modules/config/zram.nix
+++ b/nixos/modules/config/zram.nix
@@ -103,12 +103,12 @@ in
         default = "zstd";
         example = "lz4";
         type = with types; either (enum [ "lzo" "lz4" "zstd" ]) str;
-        description = ''
-          Compression algorithm. <literal>lzo</literal> has good compression,
-          but is slow. <literal>lz4</literal> has bad compression, but is fast.
-          <literal>zstd</literal> is both good compression and fast, but requires newer kernel.
+        description = lib.mdDoc ''
+          Compression algorithm. `lzo` has good compression,
+          but is slow. `lz4` has bad compression, but is fast.
+          `zstd` is both good compression and fast, but requires newer kernel.
           You can check what other algorithms are supported by your zram device with
-          <command>cat /sys/class/block/zram*/comp_algorithm</command>
+          {command}`cat /sys/class/block/zram*/comp_algorithm`
         '';
       };
     };