about summary refs log tree commit diff
path: root/nixos/modules/config/xdg/autostart.nix
diff options
context:
space:
mode:
authorworldofpeace <worldofpeace@protonmail.ch>2020-04-01 21:22:26 -0400
committerGitHub <noreply@github.com>2020-04-01 21:22:26 -0400
commit7f6dda737a11165c71128f46c631b3cd4dfadbda (patch)
treefa4b78a93b55f4597d892f69b2788676e2c2920a /nixos/modules/config/xdg/autostart.nix
parenta42fbd6210dca824ed8cf6c0f2911c4964f35c4b (diff)
parentb0ac19e050676d9c6b07ec3f8cc9c7ab7487333a (diff)
downloadnixlib-7f6dda737a11165c71128f46c631b3cd4dfadbda.tar
nixlib-7f6dda737a11165c71128f46c631b3cd4dfadbda.tar.gz
nixlib-7f6dda737a11165c71128f46c631b3cd4dfadbda.tar.bz2
nixlib-7f6dda737a11165c71128f46c631b3cd4dfadbda.tar.lz
nixlib-7f6dda737a11165c71128f46c631b3cd4dfadbda.tar.xz
nixlib-7f6dda737a11165c71128f46c631b3cd4dfadbda.tar.zst
nixlib-7f6dda737a11165c71128f46c631b3cd4dfadbda.zip
Merge pull request #84059 from worldofpeace/teams-nixos
nixos: add freedesktop/gnome/myself maintainers
Diffstat (limited to 'nixos/modules/config/xdg/autostart.nix')
-rw-r--r--nixos/modules/config/xdg/autostart.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/nixos/modules/config/xdg/autostart.nix b/nixos/modules/config/xdg/autostart.nix
index 0ee94fed818b..40984cb5ec53 100644
--- a/nixos/modules/config/xdg/autostart.nix
+++ b/nixos/modules/config/xdg/autostart.nix
@@ -2,19 +2,23 @@
 
 with lib;
 {
+  meta = {
+    maintainers = teams.freedesktop.members;
+  };
+
   options = {
     xdg.autostart.enable = mkOption {
       type = types.bool;
       default = true;
       description = ''
-        Whether to install files to support the 
+        Whether to install files to support the
         <link xlink:href="https://specifications.freedesktop.org/autostart-spec/autostart-spec-latest.html">XDG Autostart specification</link>.
       '';
     };
   };
 
   config = mkIf config.xdg.autostart.enable {
-    environment.pathsToLink = [ 
+    environment.pathsToLink = [
       "/etc/xdg/autostart"
     ];
   };