about summary refs log tree commit diff
path: root/nixos/modules/config/users-groups.nix
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2018-04-11 14:55:52 +0200
committerFrederik Rietdijk <fridh@fridh.nl>2018-04-11 14:55:52 +0200
commitee6894ca1297afe0caf2f389c1f9a9220826b749 (patch)
tree02f96b5744cef8bc55010fb8301f5b50c0748d4c /nixos/modules/config/users-groups.nix
parent392874b9b1411dc7b879997bd8776b921feea61d (diff)
parent617c26df84d5670574864a9ccad0eaf8708bd86a (diff)
downloadnixlib-ee6894ca1297afe0caf2f389c1f9a9220826b749.tar
nixlib-ee6894ca1297afe0caf2f389c1f9a9220826b749.tar.gz
nixlib-ee6894ca1297afe0caf2f389c1f9a9220826b749.tar.bz2
nixlib-ee6894ca1297afe0caf2f389c1f9a9220826b749.tar.lz
nixlib-ee6894ca1297afe0caf2f389c1f9a9220826b749.tar.xz
nixlib-ee6894ca1297afe0caf2f389c1f9a9220826b749.tar.zst
nixlib-ee6894ca1297afe0caf2f389c1f9a9220826b749.zip
Merge staging into master
Diffstat (limited to 'nixos/modules/config/users-groups.nix')
-rw-r--r--nixos/modules/config/users-groups.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/config/users-groups.nix b/nixos/modules/config/users-groups.nix
index 42d5d233f1c1..621ca36fb6b8 100644
--- a/nixos/modules/config/users-groups.nix
+++ b/nixos/modules/config/users-groups.nix
@@ -92,7 +92,7 @@ let
 
       group = mkOption {
         type = types.str;
-        apply = x: assert (builtins.stringLength x < 17 || abort "Group name '${x}' is longer than 16 characters which is not allowed!"); x;
+        apply = x: assert (builtins.stringLength x < 32 || abort "Group name '${x}' is longer than 31 characters which is not allowed!"); x;
         default = "nogroup";
         description = "The user's primary group.";
       };