about summary refs log tree commit diff
path: root/nixos/modules/config/system-environment.nix
diff options
context:
space:
mode:
authorworldofpeace <worldofpeace@protonmail.ch>2019-10-05 09:43:47 -0400
committerworldofpeace <worldofpeace@protonmail.ch>2019-10-05 09:43:47 -0400
commit57481b7a1c1e8c7c835009e1c7ad89d2f7b3d898 (patch)
tree21d9717b46f52f482505734c8961fb2226521aaf /nixos/modules/config/system-environment.nix
parent99df63be0a5fc3623a9953188f2700b44898fec7 (diff)
downloadnixlib-57481b7a1c1e8c7c835009e1c7ad89d2f7b3d898.tar
nixlib-57481b7a1c1e8c7c835009e1c7ad89d2f7b3d898.tar.gz
nixlib-57481b7a1c1e8c7c835009e1c7ad89d2f7b3d898.tar.bz2
nixlib-57481b7a1c1e8c7c835009e1c7ad89d2f7b3d898.tar.lz
nixlib-57481b7a1c1e8c7c835009e1c7ad89d2f7b3d898.tar.xz
nixlib-57481b7a1c1e8c7c835009e1c7ad89d2f7b3d898.tar.zst
nixlib-57481b7a1c1e8c7c835009e1c7ad89d2f7b3d898.zip
nixos/system-environment: use pam syntax for home variable
Diffstat (limited to 'nixos/modules/config/system-environment.nix')
-rw-r--r--nixos/modules/config/system-environment.nix4
1 files changed, 1 insertions, 3 deletions
diff --git a/nixos/modules/config/system-environment.nix b/nixos/modules/config/system-environment.nix
index 4b663ebf85a4..361c3cfc553d 100644
--- a/nixos/modules/config/system-environment.nix
+++ b/nixos/modules/config/system-environment.nix
@@ -78,9 +78,7 @@ in
         # We're trying to use the same syntax for PAM variables and env variables.
         # That means we need to map the env variables that people might use to their
         # equivalent PAM variable.
-        # Note: PAM_USER is a PAM_ITEM, HOME is an environment variable, they have 
-        # different syntax.
-        replaceEnvVars = replaceStrings ["$HOME" "$USER"] ["\${HOME}" "@{PAM_USER}"];
+        replaceEnvVars = replaceStrings ["$HOME" "$USER"] ["@{HOME}" "@{PAM_USER}"];
 
         pamVariable = n: v:
           ''${n}   DEFAULT="${concatStringsSep ":" (map replaceEnvVars (toList v))}"'';