about summary refs log tree commit diff
path: root/nixos/modules/config/system-environment.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2014-06-10 13:03:44 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-06-10 13:03:44 +0200
commit491c088731022463978e595956427e72db6306a9 (patch)
tree7b72dcd17ad081d12fbf24d39b0cd4c12a0651f2 /nixos/modules/config/system-environment.nix
parent9265a61453f0df3a8bbaf3dc53e32c239e3bdcf9 (diff)
downloadnixlib-491c088731022463978e595956427e72db6306a9.tar
nixlib-491c088731022463978e595956427e72db6306a9.tar.gz
nixlib-491c088731022463978e595956427e72db6306a9.tar.bz2
nixlib-491c088731022463978e595956427e72db6306a9.tar.lz
nixlib-491c088731022463978e595956427e72db6306a9.tar.xz
nixlib-491c088731022463978e595956427e72db6306a9.tar.zst
nixlib-491c088731022463978e595956427e72db6306a9.zip
Revert "Merge #2692: Use pam_env to properly setup system-wide env"
This reverts commit 18a0cdd86416a8cbc263cfa8cb96c460a53f7b5c.
Diffstat (limited to 'nixos/modules/config/system-environment.nix')
-rw-r--r--nixos/modules/config/system-environment.nix56
1 files changed, 0 insertions, 56 deletions
diff --git a/nixos/modules/config/system-environment.nix b/nixos/modules/config/system-environment.nix
deleted file mode 100644
index b30c4e064750..000000000000
--- a/nixos/modules/config/system-environment.nix
+++ /dev/null
@@ -1,56 +0,0 @@
-# This module defines a system-wide environment that will be
-# initialised by pam_env (that is, not only in shells).
-{ config, lib, pkgs, ... }:
-
-with lib;
-
-let
-
-  cfg = config.environment;
-
-in
-
-{
-
-  options = {
-
-    environment.systemVariables = mkOption {
-      default = {};
-      description = ''
-        A set of environment variables used in the global environment.
-        These variables will be set by PAM.
-        The value of each variable can be either a string or a list of
-        strings.  The latter is concatenated, interspersed with colon
-        characters.
-      '';
-      type = types.attrsOf (mkOptionType {
-        name = "a string or a list of strings";
-        merge = loc: defs:
-          let
-            defs' = filterOverrides defs;
-            res = (head defs').value;
-          in
-          if isList res then concatLists (getValues defs')
-          else if lessThan 1 (length defs') then
-            throw "The option `${showOption loc}' is defined multiple times, in ${showFiles (getFiles defs)}."
-          else if !isString res then
-            throw "The option `${showOption loc}' does not have a string value, in ${showFiles (getFiles defs)}."
-          else res;
-      });
-      apply = mapAttrs (n: v: if isList v then concatStringsSep ":" v else v);
-    };
-
-  };
-
-  config = {
-
-    system.build.pamEnvironment = pkgs.writeText "pam-environment"
-       ''
-         ${concatStringsSep "\n" (
-           (mapAttrsToList (n: v: ''${n}="${concatStringsSep ":" v}"'')
-             (zipAttrsWith (const concatLists) ([ (mapAttrs (n: v: [ v ]) cfg.systemVariables) ]))))}
-       '';
-
-  };
-
-}