about summary refs log tree commit diff
path: root/nixos/modules/config/shells-environment.nix
diff options
context:
space:
mode:
authorworldofpeace <worldofpeace@protonmail.ch>2019-09-18 11:15:26 -0400
committerGitHub <noreply@github.com>2019-09-18 11:15:26 -0400
commitee29fbd9a2f6b6f8222e4a0711baeb404406aedd (patch)
tree095b65e8904a711c898b300fbdc83b31a6a6d60c /nixos/modules/config/shells-environment.nix
parenteb59755f70b5f3d675de509178ebc57346d6601b (diff)
parent6663a795a3da44555f01cc04b90edd4157306bbb (diff)
downloadnixlib-ee29fbd9a2f6b6f8222e4a0711baeb404406aedd.tar
nixlib-ee29fbd9a2f6b6f8222e4a0711baeb404406aedd.tar.gz
nixlib-ee29fbd9a2f6b6f8222e4a0711baeb404406aedd.tar.bz2
nixlib-ee29fbd9a2f6b6f8222e4a0711baeb404406aedd.tar.lz
nixlib-ee29fbd9a2f6b6f8222e4a0711baeb404406aedd.tar.xz
nixlib-ee29fbd9a2f6b6f8222e4a0711baeb404406aedd.tar.zst
nixlib-ee29fbd9a2f6b6f8222e4a0711baeb404406aedd.zip
Merge pull request #68492 from worldofpeace/pam-sessionvariables
Introduce environment.profileRelativeSessionVariables
Diffstat (limited to 'nixos/modules/config/shells-environment.nix')
-rw-r--r--nixos/modules/config/shells-environment.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/nixos/modules/config/shells-environment.nix b/nixos/modules/config/shells-environment.nix
index 9dfc1add8299..d939cbb393ee 100644
--- a/nixos/modules/config/shells-environment.nix
+++ b/nixos/modules/config/shells-environment.nix
@@ -157,6 +157,8 @@ in
     # terminal instead of logging out of X11).
     environment.variables = config.environment.sessionVariables;
 
+    environment.profileRelativeEnvVars = config.environment.profileRelativeSessionVariables;
+
     environment.shellAliases = mapAttrs (name: mkDefault) {
       ls = "ls --color=tty";
       ll = "ls -l";