about summary refs log tree commit diff
path: root/nixos/modules/config/power-management.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-30 17:37:45 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-30 18:47:43 +0100
commit408b8b5725c3e6fff75aef772da248d3e95ff414 (patch)
tree692e3b61dbbff85cc97e3becf13a1376dea04a92 /nixos/modules/config/power-management.nix
parentd882e1966251880240599d3c1b31e060661506ee (diff)
downloadnixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.gz
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.bz2
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.lz
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.xz
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.zst
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.zip
Add lots of missing option types
Diffstat (limited to 'nixos/modules/config/power-management.nix')
-rw-r--r--nixos/modules/config/power-management.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/nixos/modules/config/power-management.nix b/nixos/modules/config/power-management.nix
index fec2c886818a..7299136235ed 100644
--- a/nixos/modules/config/power-management.nix
+++ b/nixos/modules/config/power-management.nix
@@ -17,6 +17,7 @@ in
     powerManagement = {
 
       enable = mkOption {
+        type = types.bool;
         default = true;
         description =
           ''
@@ -26,11 +27,13 @@ in
       };
 
       resumeCommands = mkOption {
+        type = types.lines;
         default = "";
         description = "Commands executed after the system resumes from suspend-to-RAM.";
       };
 
       powerUpCommands = mkOption {
+        type = types.lines;
         default = "";
         example = "${pkgs.hdparm}/sbin/hdparm -B 255 /dev/sda";
         description =
@@ -42,6 +45,7 @@ in
       };
 
       powerDownCommands = mkOption {
+        type = types.lines;
         default = "";
         example = "${pkgs.hdparm}/sbin/hdparm -B 255 /dev/sda";
         description =