about summary refs log tree commit diff
path: root/nixos/modules/config/malloc.nix
diff options
context:
space:
mode:
authorvolth <volth@volth.com>2019-08-13 21:52:01 +0000
committervolth <volth@volth.com>2019-08-26 21:40:19 +0000
commit35d68ef143412f579544eaac7aaa87e29f84b15e (patch)
tree7e4cc2079e73fde7e1cacdbeb17a4ea290f0a02e /nixos/modules/config/malloc.nix
parentfe9c9f719d143632d31ac2b01f5f7cfbad161ce1 (diff)
downloadnixlib-35d68ef143412f579544eaac7aaa87e29f84b15e.tar
nixlib-35d68ef143412f579544eaac7aaa87e29f84b15e.tar.gz
nixlib-35d68ef143412f579544eaac7aaa87e29f84b15e.tar.bz2
nixlib-35d68ef143412f579544eaac7aaa87e29f84b15e.tar.lz
nixlib-35d68ef143412f579544eaac7aaa87e29f84b15e.tar.xz
nixlib-35d68ef143412f579544eaac7aaa87e29f84b15e.tar.zst
nixlib-35d68ef143412f579544eaac7aaa87e29f84b15e.zip
treewide: remove redundant quotes
Diffstat (limited to 'nixos/modules/config/malloc.nix')
-rw-r--r--nixos/modules/config/malloc.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/nixos/modules/config/malloc.nix b/nixos/modules/config/malloc.nix
index 65130454735c..a528de406498 100644
--- a/nixos/modules/config/malloc.nix
+++ b/nixos/modules/config/malloc.nix
@@ -6,7 +6,7 @@ let
 
   # The set of alternative malloc(3) providers.
   providers = {
-    "graphene-hardened" = rec {
+    graphene-hardened = rec {
       libPath = "${pkgs.graphene-hardened-malloc}/lib/libhardened_malloc.so";
       description = ''
         An allocator designed to mitigate memory corruption attacks, such as
@@ -14,7 +14,7 @@ let
       '';
     };
 
-    "jemalloc" = {
+    jemalloc = {
       libPath = "${pkgs.jemalloc}/lib/libjemalloc.so";
       description = ''
         A general purpose allocator that emphasizes fragmentation avoidance
@@ -22,7 +22,7 @@ let
       '';
     };
 
-    "scudo" = {
+    scudo = {
       libPath = "${pkgs.llvmPackages.compiler-rt}/lib/linux/libclang_rt.scudo-x86_64.so";
       description = ''
         A user-mode allocator based on LLVM Sanitizer’s CombinedAllocator,
@@ -32,7 +32,7 @@ let
     };
   };
 
-  providerConf = providers."${cfg.provider}";
+  providerConf = providers.${cfg.provider};
 
   # An output that contains only the shared library, to avoid
   # needlessly bloating the system closure