about summary refs log tree commit diff
path: root/nixos/lib/testing.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2014-04-14 14:02:44 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-04-14 14:02:44 +0200
commitabe218950c779fd1c98034356d3b324d66a0d30a (patch)
tree13d9cd800477089920e53ad51795b53f2fb97535 /nixos/lib/testing.nix
parent753639e548b32c7afd642e8a9823f6b4205330b6 (diff)
downloadnixlib-abe218950c779fd1c98034356d3b324d66a0d30a.tar
nixlib-abe218950c779fd1c98034356d3b324d66a0d30a.tar.gz
nixlib-abe218950c779fd1c98034356d3b324d66a0d30a.tar.bz2
nixlib-abe218950c779fd1c98034356d3b324d66a0d30a.tar.lz
nixlib-abe218950c779fd1c98034356d3b324d66a0d30a.tar.xz
nixlib-abe218950c779fd1c98034356d3b324d66a0d30a.tar.zst
nixlib-abe218950c779fd1c98034356d3b324d66a0d30a.zip
Make it easier to run the tests
You can now run a test in the nixos/tests directory directly using
nix-build, e.g.

  $ nix-build '<nixos/tests/login.nix>' -A test

This gets rid of having to add the test to nixos/tests/default.nix.
(Of course, you still need to add it to nixos/release.nix if you want
Hydra to run the test.)
Diffstat (limited to 'nixos/lib/testing.nix')
-rw-r--r--nixos/lib/testing.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/nixos/lib/testing.nix b/nixos/lib/testing.nix
index d5338bc04cac..02d865895fbb 100644
--- a/nixos/lib/testing.nix
+++ b/nixos/lib/testing.nix
@@ -73,7 +73,7 @@ rec {
   apply = makeTest; # compatibility
   call = f: f { inherit pkgs system; };
 
-  complete = { testScript, ... } @ t: t // rec {
+  complete = { testScript, makeCoverageReport ? false, ... } @ t: t // rec {
 
     nodes = buildVirtualNetwork (
       t.nodes or (if t ? machine then { machine = t.machine; } else { }));
@@ -117,6 +117,8 @@ rec {
     test = runTests driver;
 
     report = releaseTools.gcovReport { coverageRuns = [ test ]; };
+
+    result = if makeCoverageReport then report else test;
   };