about summary refs log tree commit diff
path: root/nixos/lib/eval-config.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-29 16:14:58 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-29 16:18:23 +0100
commit89b1dd8ddec8ee50630855fc8a63835754f23e54 (patch)
treeed1d653bba9ccd0ce13090500d684277348022d9 /nixos/lib/eval-config.nix
parentc407db6316fc3f7b5986b879d62e2a57f26d3407 (diff)
downloadnixlib-89b1dd8ddec8ee50630855fc8a63835754f23e54.tar
nixlib-89b1dd8ddec8ee50630855fc8a63835754f23e54.tar.gz
nixlib-89b1dd8ddec8ee50630855fc8a63835754f23e54.tar.bz2
nixlib-89b1dd8ddec8ee50630855fc8a63835754f23e54.tar.lz
nixlib-89b1dd8ddec8ee50630855fc8a63835754f23e54.tar.xz
nixlib-89b1dd8ddec8ee50630855fc8a63835754f23e54.tar.zst
nixlib-89b1dd8ddec8ee50630855fc8a63835754f23e54.zip
Fix environment.checkConfigurationOptions
This requires delaying the declaredness check until later, otherwise
we get an infinite recursion querying
environment.checkConfigurationOptions.
Diffstat (limited to 'nixos/lib/eval-config.nix')
-rw-r--r--nixos/lib/eval-config.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/lib/eval-config.nix b/nixos/lib/eval-config.nix
index ece78691a848..5e1ce69158fd 100644
--- a/nixos/lib/eval-config.nix
+++ b/nixos/lib/eval-config.nix
@@ -19,7 +19,7 @@ rec {
   inherit (pkgs.lib.evalModules {
     modules = modules ++ baseModules;
     args = extraArgs;
-    inherit check;
+    check = check && options.environment.checkConfigurationOptions.value;
   }) config options;
 
   # These are the extra arguments passed to every module.  In