about summary refs log tree commit diff
path: root/modules/workstation/windowing/sway/default.nix
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2023-06-16 10:28:38 +0000
committerAlyssa Ross <hi@alyssa.is>2023-08-05 09:35:26 +0000
commit635f5ea350f375d183ef6994691cf9c47f84191e (patch)
tree08126b3b7abadf69ffec16cf0cf751f321d99479 /modules/workstation/windowing/sway/default.nix
parent7517820d73ff3edcc8da721931aeeaf206929650 (diff)
downloadnixlib-635f5ea350f375d183ef6994691cf9c47f84191e.tar
nixlib-635f5ea350f375d183ef6994691cf9c47f84191e.tar.gz
nixlib-635f5ea350f375d183ef6994691cf9c47f84191e.tar.bz2
nixlib-635f5ea350f375d183ef6994691cf9c47f84191e.tar.lz
nixlib-635f5ea350f375d183ef6994691cf9c47f84191e.tar.xz
nixlib-635f5ea350f375d183ef6994691cf9c47f84191e.tar.zst
nixlib-635f5ea350f375d183ef6994691cf9c47f84191e.zip
modules: use Markdown documentation descriptions
Diffstat (limited to 'modules/workstation/windowing/sway/default.nix')
-rw-r--r--modules/workstation/windowing/sway/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/modules/workstation/windowing/sway/default.nix b/modules/workstation/windowing/sway/default.nix
index baaad51b8f3c..07b61c3e1c0f 100644
--- a/modules/workstation/windowing/sway/default.nix
+++ b/modules/workstation/windowing/sway/default.nix
@@ -1,7 +1,7 @@
 { pkgs, lib, config, ... }:
 
 let
-  inherit (lib) mkOption optionalString;
+  inherit (lib) mdDoc mkOption optionalString;
   inherit (lib.types) lines nullOr path;
   inherit (pkgs) callPackage substituteAll;
 
@@ -14,13 +14,13 @@ in
   options = {
     programs.sway.extraConfig = mkOption {
       type = lines;
-      description = "Lines to append to sway's config file";
+      description = mdDoc "Lines to append to sway's config file";
       default = "";
     };
 
     programs.sway.wallpaper = mkOption {
       type = nullOr path;
-      description = "Path to wallpaper for sway and swaylock";
+      description = mdDoc "Path to wallpaper for sway and swaylock";
       default = null;
     };
   };