about summary refs log tree commit diff
path: root/modules/workstation/weechat/default.nix
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2020-12-01 03:17:58 +0000
committerAlyssa Ross <hi@alyssa.is>2020-12-04 16:59:39 +0000
commit5b3c9052ee1d946de81400768f5dcecf44347999 (patch)
treedb17695cb969625d68fe86937de5fce473a50153 /modules/workstation/weechat/default.nix
parent888fafae2b25df566c107585e57d32a59e21bbee (diff)
downloadnixlib-5b3c9052ee1d946de81400768f5dcecf44347999.tar
nixlib-5b3c9052ee1d946de81400768f5dcecf44347999.tar.gz
nixlib-5b3c9052ee1d946de81400768f5dcecf44347999.tar.bz2
nixlib-5b3c9052ee1d946de81400768f5dcecf44347999.tar.lz
nixlib-5b3c9052ee1d946de81400768f5dcecf44347999.tar.xz
nixlib-5b3c9052ee1d946de81400768f5dcecf44347999.tar.zst
nixlib-5b3c9052ee1d946de81400768f5dcecf44347999.zip
modules/weechat: remove wee-slack
Hopefully I'm never using Slack again
Diffstat (limited to 'modules/workstation/weechat/default.nix')
-rw-r--r--modules/workstation/weechat/default.nix9
1 files changed, 2 insertions, 7 deletions
diff --git a/modules/workstation/weechat/default.nix b/modules/workstation/weechat/default.nix
index a7ad110e1c66..c8f48a4aa985 100644
--- a/modules/workstation/weechat/default.nix
+++ b/modules/workstation/weechat/default.nix
@@ -11,7 +11,7 @@ let
     else if isList value   then concatStringsSep "," value
     else toString value;
 
-  sec = [ "znc.username" "znc.password" "slack.api_tokens" ];
+  sec = [ "znc.username" "znc.password" ];
 
   cfgin = {
     alias.cmd.B = "buffer";
@@ -38,11 +38,6 @@ let
     logger.color.backlog_end = "*default";
     logger.look.backlog = 200;
 
-    plugins.var.python.slack.slack_api_token = "\\\${sec.data.slack.api_tokens}";
-    plugins.var.python.slack.auto_open_threads = true;
-    plugins.var.python.slack.background_load_all_history = true;
-    plugins.var.python.slack.short_buffer_names = true;
-    plugins.var.python.slack.show_reaction_nicks = true;
 
     script.look.sort = "p,n";
 
@@ -105,7 +100,7 @@ in
     (weechat.override {
       configure = { availablePlugins, ... }: {
         scripts = with weechatScripts;
-          [ colorize_nicks go wee-slack zncplayback ];
+          [ colorize_nicks go zncplayback ];
       };
     })
   ];