about summary refs log tree commit diff
path: root/modules/workstation/mail/default.nix
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2019-10-15 20:24:24 +0000
committerAlyssa Ross <hi@alyssa.is>2019-10-15 20:24:24 +0000
commitde27852f4f7c3ab53e5bc19b4b619dcff6cf1b4f (patch)
treed1b1162a54f53abd03847779f580739dfb689342 /modules/workstation/mail/default.nix
parent7ef530000efea9173bf10b687ecd895625c1958c (diff)
downloadnixlib-de27852f4f7c3ab53e5bc19b4b619dcff6cf1b4f.tar
nixlib-de27852f4f7c3ab53e5bc19b4b619dcff6cf1b4f.tar.gz
nixlib-de27852f4f7c3ab53e5bc19b4b619dcff6cf1b4f.tar.bz2
nixlib-de27852f4f7c3ab53e5bc19b4b619dcff6cf1b4f.tar.lz
nixlib-de27852f4f7c3ab53e5bc19b4b619dcff6cf1b4f.tar.xz
nixlib-de27852f4f7c3ab53e5bc19b4b619dcff6cf1b4f.tar.zst
nixlib-de27852f4f7c3ab53e5bc19b4b619dcff6cf1b4f.zip
modules/mail: replace msmtp with postfix
Using a full MTA might seem like overkill, but it fixes my biggest
annoyance with msmtp -- not only can I now read mail while offline, I
can send it too, and postfix will just keep trying every so often
until it sends (or five days have passed, but at that point the
message is probably irrelevant anyway).

Postfix's defaults are surprisingly good for this use case.  The
longest it will wait between attempts is 4000 seconds, and it'll keep
trying for five days before giving up and bouncing.
Diffstat (limited to 'modules/workstation/mail/default.nix')
-rw-r--r--modules/workstation/mail/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/workstation/mail/default.nix b/modules/workstation/mail/default.nix
index 4564a2dee1c9..e33b7a702823 100644
--- a/modules/workstation/mail/default.nix
+++ b/modules/workstation/mail/default.nix
@@ -7,7 +7,7 @@ let
 in
 
 {
-  imports = [ ./msmtp ./mutt ./notmuch ];
+  imports = [ ./mutt ./notmuch ./postfix ];
 
   environment.systemPackages = with pkgs; [ isync ];