about summary refs log tree commit diff
path: root/modules/workstation/lorri/default.nix
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2021-01-13 08:36:07 +0000
committerAlyssa Ross <hi@alyssa.is>2021-01-13 08:52:28 +0000
commit9f55e8bc0fb7cf1b0204652871808130a45e8eee (patch)
tree94ee10ed32721a43261d3b696d5597b4457b5028 /modules/workstation/lorri/default.nix
parent1fb3ddfe362432c508409a81060dfd4bbb2ce31f (diff)
downloadnixlib-9f55e8bc0fb7cf1b0204652871808130a45e8eee.tar
nixlib-9f55e8bc0fb7cf1b0204652871808130a45e8eee.tar.gz
nixlib-9f55e8bc0fb7cf1b0204652871808130a45e8eee.tar.bz2
nixlib-9f55e8bc0fb7cf1b0204652871808130a45e8eee.tar.lz
nixlib-9f55e8bc0fb7cf1b0204652871808130a45e8eee.tar.xz
nixlib-9f55e8bc0fb7cf1b0204652871808130a45e8eee.tar.zst
nixlib-9f55e8bc0fb7cf1b0204652871808130a45e8eee.zip
modules/home: remove
I think when I implemented this I didn't know about tmpfiles.d(5).
Now I do, so let's use that instead.

I don't think the imperativeNix option is necessary any more since the
home directory is created read-only, but if it turns out that
.nix-defexpr and .nix-profile are coming back, I can look into the
best way to solve that then.
Diffstat (limited to 'modules/workstation/lorri/default.nix')
-rw-r--r--modules/workstation/lorri/default.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/modules/workstation/lorri/default.nix b/modules/workstation/lorri/default.nix
index 4008934dab01..c740796bafbb 100644
--- a/modules/workstation/lorri/default.nix
+++ b/modules/workstation/lorri/default.nix
@@ -1,7 +1,9 @@
-{ ... }:
+{ config, ... }:
 
 {
-  home.qyliss.dirs."state/lorri" = {};
+  systemd.tmpfiles.rules = [
+    "d ${config.users.users.qyliss.home}/state/lorri 0700 qyliss qyliss"
+  ];
 
   services.lorri.enable = true;