about summary refs log tree commit diff
path: root/modules/server/spectrum/postfix/default.nix
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2023-06-05 15:58:38 +0000
committerAlyssa Ross <hi@alyssa.is>2023-06-05 20:44:37 +0000
commit11e957cd981461d4f9c0c32f1c5eba160dc156ad (patch)
tree22108da984c9db3f9afe4e45b772aa1a8b632478 /modules/server/spectrum/postfix/default.nix
parent03b12c28b04544d358806fa32b57b12214f55365 (diff)
downloadnixlib-11e957cd981461d4f9c0c32f1c5eba160dc156ad.tar
nixlib-11e957cd981461d4f9c0c32f1c5eba160dc156ad.tar.gz
nixlib-11e957cd981461d4f9c0c32f1c5eba160dc156ad.tar.bz2
nixlib-11e957cd981461d4f9c0c32f1c5eba160dc156ad.tar.lz
nixlib-11e957cd981461d4f9c0c32f1c5eba160dc156ad.tar.xz
nixlib-11e957cd981461d4f9c0c32f1c5eba160dc156ad.tar.zst
nixlib-11e957cd981461d4f9c0c32f1c5eba160dc156ad.zip
modules/spectrum/postfix: don't use p-i spamc
The public-inbox spamassassin rules are not all that useful, and make
the setup more complicated.
Diffstat (limited to 'modules/server/spectrum/postfix/default.nix')
-rw-r--r--modules/server/spectrum/postfix/default.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/modules/server/spectrum/postfix/default.nix b/modules/server/spectrum/postfix/default.nix
index 3dbe16643714..16c2acf95269 100644
--- a/modules/server/spectrum/postfix/default.nix
+++ b/modules/server/spectrum/postfix/default.nix
@@ -48,7 +48,7 @@
     chroot = false;
     command = "pipe";
     args = [
-      "user=public-inbox" # FIXME: this is a hack because public-inbox has ~/.spamassassin
+      "user=postfix-spamc"
       "argv=${pkgs.spamassassin}/bin/spamc"
       "-f"
       "-e"
@@ -61,4 +61,10 @@
   };
 
   networking.firewall.allowedTCPPorts = [ 25 ];
+
+  users.groups.postfix-spamc = {};
+  users.users.postfix-spamc = {
+    group = "postfix-spamc";
+    isSystemUser = true;
+  };
 }