about summary refs log tree commit diff
path: root/modules/server/spectrum/default.nix
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2021-01-12 13:52:51 +0000
committerAlyssa Ross <hi@alyssa.is>2021-01-12 14:07:25 +0000
commite24dc3e236719c488fe57f33375947ba9134e175 (patch)
treef40aa5b3da36f86febdae1fc114cada6547ea187 /modules/server/spectrum/default.nix
parent46ec819d56fc3f39ed4951edb782c755a59ed8e4 (diff)
downloadnixlib-e24dc3e236719c488fe57f33375947ba9134e175.tar
nixlib-e24dc3e236719c488fe57f33375947ba9134e175.tar.gz
nixlib-e24dc3e236719c488fe57f33375947ba9134e175.tar.bz2
nixlib-e24dc3e236719c488fe57f33375947ba9134e175.tar.lz
nixlib-e24dc3e236719c488fe57f33375947ba9134e175.tar.xz
nixlib-e24dc3e236719c488fe57f33375947ba9134e175.tar.zst
nixlib-e24dc3e236719c488fe57f33375947ba9134e175.zip
sys/atuin: update for new ACME module
The new module defaults to using an "acme" group, which can replace
the "tls" group I had set up before.  But it will instead use the
"nginx" group if using enableACME, so I have to stay away from that
and only use useACMEHost, setting up the certificates manually.

But that's a very good thing, because it turns out that even though I
was trying to generate only two certificates (one for qyliss.net and
one for spectrum-os.org), the ACME module was actually generating one
per subdomain because of enableACME.

Finally, now that atuin.nix is starting to be split up, and because
there's less shared configuration, don't mapAttrs over Nginx virtual
hosts or ACME certificates, which was confusing and forced everything
to be defined at once in the same file.
Diffstat (limited to 'modules/server/spectrum/default.nix')
-rw-r--r--modules/server/spectrum/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/server/spectrum/default.nix b/modules/server/spectrum/default.nix
index d8f096c2d820..c18355a4946a 100644
--- a/modules/server/spectrum/default.nix
+++ b/modules/server/spectrum/default.nix
@@ -1,5 +1,5 @@
 { ... }:
 
 {
-  imports = [ ./cgit ./git-http-backend ./nginx ./public-inbox ];
+  imports = [ ./acme ./cgit ./git-http-backend ./nginx ./public-inbox ];
 }