about summary refs log tree commit diff
path: root/modules/home/default.nix
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2019-02-10 19:59:18 +0000
committerAlyssa Ross <hi@alyssa.is>2019-02-10 19:59:18 +0000
commite0a178df252d6801108699fa07cd1ea494ebc12d (patch)
tree13217ea9caf3b75a9ff81351ee747d291a1a784a /modules/home/default.nix
parent2349ca0a596f73209c7491769879c065db513ca6 (diff)
downloadnixlib-e0a178df252d6801108699fa07cd1ea494ebc12d.tar
nixlib-e0a178df252d6801108699fa07cd1ea494ebc12d.tar.gz
nixlib-e0a178df252d6801108699fa07cd1ea494ebc12d.tar.bz2
nixlib-e0a178df252d6801108699fa07cd1ea494ebc12d.tar.lz
nixlib-e0a178df252d6801108699fa07cd1ea494ebc12d.tar.xz
nixlib-e0a178df252d6801108699fa07cd1ea494ebc12d.tar.zst
nixlib-e0a178df252d6801108699fa07cd1ea494ebc12d.zip
config: give up on this experiment
This ended up being way more trouble than it was worth, and the approach
just flat out didn't work for stuff like OpenSSH.
Diffstat (limited to 'modules/home/default.nix')
-rw-r--r--modules/home/default.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/modules/home/default.nix b/modules/home/default.nix
index 0ad1cb85b255..780bac85b334 100644
--- a/modules/home/default.nix
+++ b/modules/home/default.nix
@@ -12,8 +12,8 @@ let
         type = nullOr str;
       };
       group = mkOption {
-        default = "users";
-        type = str;
+        default = null;
+        type = nullOr str;
       };
       permissions = mkOption {
         default = "0700";
@@ -31,10 +31,12 @@ let
       owner = if dir.owner == null
               then user
               else config.users.users.${dir.owner};
+
+      group = if dir.group == null then owner.group else dir.group;
     in
       ''
         chmod ${dir.permissions} .
-        chown ${owner.name}:${dir.group} .
+        chown ${owner.name}:${group} .
         ${concatStringsSep "\n" (attrValues dir.activationScripts)}
       '';