about summary refs log tree commit diff
path: root/maintainers/scripts/eval-release.nix
diff options
context:
space:
mode:
authorYury G. Kudryashov <urkud.urkud@gmail.com>2012-01-24 19:10:54 +0000
committerYury G. Kudryashov <urkud.urkud@gmail.com>2012-01-24 19:10:54 +0000
commit954c8cdac1eedf26bcd8a0961203c4f7b1c3b55b (patch)
tree7c2d6321d7998360b75ec88855a799e1a3c4d4a9 /maintainers/scripts/eval-release.nix
parentc7dc7f5e871aea8495be86d5fd70dab118355b62 (diff)
downloadnixlib-954c8cdac1eedf26bcd8a0961203c4f7b1c3b55b.tar
nixlib-954c8cdac1eedf26bcd8a0961203c4f7b1c3b55b.tar.gz
nixlib-954c8cdac1eedf26bcd8a0961203c4f7b1c3b55b.tar.bz2
nixlib-954c8cdac1eedf26bcd8a0961203c4f7b1c3b55b.tar.lz
nixlib-954c8cdac1eedf26bcd8a0961203c4f7b1c3b55b.tar.xz
nixlib-954c8cdac1eedf26bcd8a0961203c4f7b1c3b55b.tar.zst
nixlib-954c8cdac1eedf26bcd8a0961203c4f7b1c3b55b.zip
test-eval-release: handle ENV{VERBOSE}.
See test-eval-release.sh for details.

svn path=/nixpkgs/trunk/; revision=31824
Diffstat (limited to 'maintainers/scripts/eval-release.nix')
-rw-r--r--maintainers/scripts/eval-release.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/maintainers/scripts/eval-release.nix b/maintainers/scripts/eval-release.nix
index 836e4312c448..7fac2a1c2ef5 100644
--- a/maintainers/scripts/eval-release.nix
+++ b/maintainers/scripts/eval-release.nix
@@ -5,6 +5,7 @@
 with import ../../pkgs/lib;
 
 let
+  trace = if (builtins.getEnv "VERBOSE") == "1" then builtins.trace else (x: y: y);
 
   rel = removeAttrs (import ../../pkgs/top-level/release.nix) [ "tarball" "xbursttools" ];
 
@@ -15,7 +16,7 @@ let
   maybe = as: let y = builtins.tryEval (strictAttrs as); in if y.success then y.value else builtins.trace "FAIL" null;
 
   call = attrs: flip mapAttrs attrs
-    (n: v: /* builtins.trace n */ (
+    (n: v: trace n (
       if builtins.isFunction v then maybe (v { system = "i686-linux"; })
       else if builtins.isAttrs v then call v
       else null