about summary refs log tree commit diff
path: root/maintainers/maintainer-list.nix
diff options
context:
space:
mode:
authorJan Malakhovski <oxij@oxij.org>2018-10-02 15:17:41 +0000
committerJan Malakhovski <oxij@oxij.org>2018-10-03 00:21:43 +0000
commitbe68971cd18226a15d4b3d784273e4d9c96872a2 (patch)
tree1d3d5ef83b0bdcd851aec5d1264d9080d11f2a89 /maintainers/maintainer-list.nix
parent5abdbbb8b7436f48463d93fa3c11f48a03a66bba (diff)
downloadnixlib-be68971cd18226a15d4b3d784273e4d9c96872a2.tar
nixlib-be68971cd18226a15d4b3d784273e4d9c96872a2.tar.gz
nixlib-be68971cd18226a15d4b3d784273e4d9c96872a2.tar.bz2
nixlib-be68971cd18226a15d4b3d784273e4d9c96872a2.tar.lz
nixlib-be68971cd18226a15d4b3d784273e4d9c96872a2.tar.xz
nixlib-be68971cd18226a15d4b3d784273e4d9c96872a2.tar.zst
nixlib-be68971cd18226a15d4b3d784273e4d9c96872a2.zip
maintainers/maintainer-list.nix: add PGP/GPG attributes
Diffstat (limited to 'maintainers/maintainer-list.nix')
-rw-r--r--maintainers/maintainer-list.nix16
1 files changed, 15 insertions, 1 deletions
diff --git a/maintainers/maintainer-list.nix b/maintainers/maintainer-list.nix
index 2b439da2a40b..04fabb190003 100644
--- a/maintainers/maintainer-list.nix
+++ b/maintainers/maintainer-list.nix
@@ -7,6 +7,10 @@
 
       # Optional
       github = "GithubUsername";
+      keys = [{
+        longkeyid = "rsa2048/0x0123456789ABCDEF";
+        fingerprint = "AAAA BBBB CCCC DDDD EEEE  FFFF 0000 1111 2222 3333";
+      }];
     };
 
   where
@@ -14,10 +18,20 @@
   - `handle` is the handle you are going to use in nixpkgs expressions,
   - `name` is your, preferably real, name,
   - `email` is your maintainer email address, and
-  - `github` is your GitHub handle (as it appears in the URL of your profile page, `https://github.com/<userhandle>`).
+  - `github` is your GitHub handle (as it appears in the URL of your profile page, `https://github.com/<userhandle>`),
+  - `keys` is a list of your PGP/GPG key IDs and fingerprints.
 
   `handle == github` is strongly preffered whenever `github` is an acceptable attribute name and is short and convenient.
 
+  Add PGP/GPG keys only if you actually use them to sign commits and/or mail.
+
+  To get the required PGP/GPG values for a key run
+  ```shell
+  gpg --keyid-format 0xlong --fingerprint <email> | head -n 2
+  ```
+
+  !!! Note that PGP/GPG values stored here are for informational purposes only, don't use this file as a source of truth.
+
   More fields may be added in the future.
 
   Please keep the list alphabetically sorted.