about summary refs log tree commit diff
path: root/maintainers/maintainer-list.nix
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2019-01-21 11:42:25 +0000
committerGitHub <noreply@github.com>2019-01-21 11:42:25 +0000
commit0ad9ad40f5aa50abf22489a9e50c32dd82fd3d7e (patch)
treec327ab8d1218e511f133cf0f3d3f7644b583ef9a /maintainers/maintainer-list.nix
parent437e478a50594ccf3508ed0688770ed9b888b78f (diff)
parent419ea86540a0e5e947fd523ae8004790d5cfda55 (diff)
downloadnixlib-0ad9ad40f5aa50abf22489a9e50c32dd82fd3d7e.tar
nixlib-0ad9ad40f5aa50abf22489a9e50c32dd82fd3d7e.tar.gz
nixlib-0ad9ad40f5aa50abf22489a9e50c32dd82fd3d7e.tar.bz2
nixlib-0ad9ad40f5aa50abf22489a9e50c32dd82fd3d7e.tar.lz
nixlib-0ad9ad40f5aa50abf22489a9e50c32dd82fd3d7e.tar.xz
nixlib-0ad9ad40f5aa50abf22489a9e50c32dd82fd3d7e.tar.zst
nixlib-0ad9ad40f5aa50abf22489a9e50c32dd82fd3d7e.zip
Merge pull request #47663 from oxij/maintainers/gpg-fingerprint
maintainers/maintainer-list.nix: add PGP/GPG fingerprints
Diffstat (limited to 'maintainers/maintainer-list.nix')
-rw-r--r--maintainers/maintainer-list.nix40
1 files changed, 32 insertions, 8 deletions
diff --git a/maintainers/maintainer-list.nix b/maintainers/maintainer-list.nix
index 222724d0a881..c78e5739c4ca 100644
--- a/maintainers/maintainer-list.nix
+++ b/maintainers/maintainer-list.nix
@@ -1,21 +1,41 @@
 /* List of NixOS maintainers.
 
     handle = {
-      name = "Real name";
+      # Required
+      name = "Your name";
       email = "address@example.org";
+
+      # Optional
       github = "GithubUsername";
+      keys = [{
+        longkeyid = "rsa2048/0x0123456789ABCDEF";
+        fingerprint = "AAAA BBBB CCCC DDDD EEEE  FFFF 0000 1111 2222 3333";
+      }];
     };
 
-  where `name` is your real name, `email` is your maintainer email
-  address and `github` is your GitHub handle (as it appears in the
-  URL of your profile page, `https://github.com/<userhandle>`).
- address
-  The only required fields are `name` and `email`.
+  where
+
+  - `handle` is the handle you are going to use in nixpkgs expressions,
+  - `name` is your, preferably real, name,
+  - `email` is your maintainer email address, and
+  - `github` is your GitHub handle (as it appears in the URL of your profile page, `https://github.com/<userhandle>`),
+  - `keys` is a list of your PGP/GPG key IDs and fingerprints.
+
+  `handle == github` is strongly preffered whenever `github` is an acceptable attribute name and is short and convenient.
+
+  Add PGP/GPG keys only if you actually use them to sign commits and/or mail.
+
+  To get the required PGP/GPG values for a key run
+  ```shell
+  gpg --keyid-format 0xlong --fingerprint <email> | head -n 2
+  ```
+
+  !!! Note that PGP/GPG values stored here are for informational purposes only, don't use this file as a source of truth.
+
   More fields may be added in the future.
 
   Please keep the list alphabetically sorted.
-  See `../maintainers/scripts/check-maintainer-github-handles.sh`
-  for an example on how to work with this data.
+  See `./scripts/check-maintainer-github-handles.sh` for an example on how to work with this data.
   */
 {
   "1000101" = {
@@ -3338,6 +3358,10 @@
     email = "oxij@oxij.org";
     github = "oxij";
     name = "Jan Malakhovski";
+    keys = [{
+      longkeyid = "rsa2048/0x0E6CA66E5C557AA8";
+      fingerprint = "514B B966 B46E 3565 0508  86E8 0E6C A66E 5C55 7AA8";
+    }];
   };
   oyren = {
     email = "m.scheuren@oyra.eu";