about summary refs log tree commit diff
path: root/lib/types.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2018-08-08 19:26:52 +0200
committerProfpatsch <mail@profpatsch.de>2018-09-06 18:14:27 +0200
commitefdf618330a22f837f0e5e446028e918a5b4dd8a (patch)
tree6b9ad4353a2e470a3bccbbdca89247047263062b /lib/types.nix
parent3e45b61a9920466a8ea06b8ad9350d56ade435bc (diff)
downloadnixlib-efdf618330a22f837f0e5e446028e918a5b4dd8a.tar
nixlib-efdf618330a22f837f0e5e446028e918a5b4dd8a.tar.gz
nixlib-efdf618330a22f837f0e5e446028e918a5b4dd8a.tar.bz2
nixlib-efdf618330a22f837f0e5e446028e918a5b4dd8a.tar.lz
nixlib-efdf618330a22f837f0e5e446028e918a5b4dd8a.tar.xz
nixlib-efdf618330a22f837f0e5e446028e918a5b4dd8a.tar.zst
nixlib-efdf618330a22f837f0e5e446028e918a5b4dd8a.zip
lib: move assertMsg and assertOneOf to their own library file
Since the `assertOneOf` uses `lib.generators`, they are not really trivial
anymore and should go into their own library file.
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/types.nix b/lib/types.nix
index 441af98cb9b6..4e44e7521c4b 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -441,7 +441,7 @@ rec {
     # Either value of type `finalType` or `coercedType`, the latter is
     # converted to `finalType` using `coerceFunc`.
     coercedTo = coercedType: coerceFunc: finalType:
-      assert assertMsg (coercedType.getSubModules == null)
+      assert lib.assertMsg (coercedType.getSubModules == null)
         "coercedTo: coercedType must not have submodules (it’s a ${
           coercedType.description})";
       mkOptionType rec {