about summary refs log tree commit diff
path: root/lib/systems/platforms.nix
diff options
context:
space:
mode:
authorDaniel Barlow <dan@telent.net>2017-12-05 10:27:45 +0000
committerJohn Ericson <John.Ericson@Obsidian.Systems>2018-02-23 20:43:42 -0500
commit9c50ae6898b2d5dccd6e030c80535fb1a32f703d (patch)
treef957c334d3b0885adcca2cefa6f90ab805443e30 /lib/systems/platforms.nix
parent2682ba63bc0c4dea159ec664d63d375a8d75b12a (diff)
downloadnixlib-9c50ae6898b2d5dccd6e030c80535fb1a32f703d.tar
nixlib-9c50ae6898b2d5dccd6e030c80535fb1a32f703d.tar.gz
nixlib-9c50ae6898b2d5dccd6e030c80535fb1a32f703d.tar.bz2
nixlib-9c50ae6898b2d5dccd6e030c80535fb1a32f703d.tar.lz
nixlib-9c50ae6898b2d5dccd6e030c80535fb1a32f703d.tar.xz
nixlib-9c50ae6898b2d5dccd6e030c80535fb1a32f703d.tar.zst
nixlib-9c50ae6898b2d5dccd6e030c80535fb1a32f703d.zip
lib, treewide: Add missing MIPS arches, and fix existing usage
Existing "mips64el" should be "mipsel".

This is just the barest minimum so that nixpkgs can recognize them as
systems - although required for building individual derivations onto
MIPS boards, it is not sufficient if you want to actually build nixos on
those targets
Diffstat (limited to 'lib/systems/platforms.nix')
-rw-r--r--lib/systems/platforms.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/systems/platforms.nix b/lib/systems/platforms.nix
index 9350a16017dd..f39e890fbf1c 100644
--- a/lib/systems/platforms.nix
+++ b/lib/systems/platforms.nix
@@ -561,6 +561,6 @@ rec {
       "armv6l-linux" = raspberrypi;
       "armv7l-linux" = armv7l-hf-multiplatform;
       "aarch64-linux" = aarch64-multiplatform;
-      "mips64el-linux" = fuloong2f_n32;
+      "mipsel-linux" = fuloong2f_n32;
     }.${system} or pcBase;
 }