about summary refs log tree commit diff
path: root/lib/systems/parse.nix
diff options
context:
space:
mode:
authorDavid McFarland <corngood@gmail.com>2017-06-12 14:27:10 -0300
committerDavid McFarland <corngood@gmail.com>2017-06-26 09:33:41 -0300
commit4ac1901d54f4301df2f09b85e2f69769ee61dfc1 (patch)
tree652726201a2530ea3e697470291bb56a9612ceab /lib/systems/parse.nix
parentbe75c5dffbc236e80d382237209434a05344f2a7 (diff)
downloadnixlib-4ac1901d54f4301df2f09b85e2f69769ee61dfc1.tar
nixlib-4ac1901d54f4301df2f09b85e2f69769ee61dfc1.tar.gz
nixlib-4ac1901d54f4301df2f09b85e2f69769ee61dfc1.tar.bz2
nixlib-4ac1901d54f4301df2f09b85e2f69769ee61dfc1.tar.lz
nixlib-4ac1901d54f4301df2f09b85e2f69769ee61dfc1.tar.xz
nixlib-4ac1901d54f4301df2f09b85e2f69769ee61dfc1.tar.zst
nixlib-4ac1901d54f4301df2f09b85e2f69769ee61dfc1.zip
stdenv: remove unix kernel family
System predicate patterns can now be specified as a list of OR'd
attribute sets.
Diffstat (limited to 'lib/systems/parse.nix')
-rw-r--r--lib/systems/parse.nix17
1 files changed, 8 insertions, 9 deletions
diff --git a/lib/systems/parse.nix b/lib/systems/parse.nix
index fdfc1cbc907f..bf21d74b931d 100644
--- a/lib/systems/parse.nix
+++ b/lib/systems/parse.nix
@@ -68,21 +68,20 @@ rec {
   isKernelFamily = isType "kernel-family";
   kernelFamilies = setTypes "kernel-family" {
     bsd = {};
-    unix = {};
   };
 
   isKernel = x: isType "kernel" x;
   kernels = with execFormats; with kernelFamilies; setTypesAssert "kernel"
     (x: isExecFormat x.execFormat && all isKernelFamily (attrValues x.families))
   {
-    darwin  = { execFormat = macho;   families = { inherit unix; }; };
-    freebsd = { execFormat = elf;     families = { inherit unix bsd; }; };
-    hurd    = { execFormat = elf;     families = { inherit unix; }; };
-    linux   = { execFormat = elf;     families = { inherit unix; }; };
-    netbsd  = { execFormat = elf;     families = { inherit unix bsd; }; };
-    none    = { execFormat = unknown; families = { inherit unix; }; };
-    openbsd = { execFormat = elf;     families = { inherit unix bsd; }; };
-    solaris = { execFormat = elf;     families = { inherit unix; }; };
+    darwin  = { execFormat = macho;   families = { }; };
+    freebsd = { execFormat = elf;     families = { inherit bsd; }; };
+    hurd    = { execFormat = elf;     families = { }; };
+    linux   = { execFormat = elf;     families = { }; };
+    netbsd  = { execFormat = elf;     families = { inherit bsd; }; };
+    none    = { execFormat = unknown; families = { }; };
+    openbsd = { execFormat = elf;     families = { inherit bsd; }; };
+    solaris = { execFormat = elf;     families = { }; };
     windows = { execFormat = pe;      families = { }; };
   } // { # aliases
     # TODO(@Ericson2314): Handle these Darwin version suffixes more generally.