about summary refs log tree commit diff
path: root/lib/systems/inspect.nix
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2018-03-19 00:16:25 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2018-03-19 12:02:49 -0400
commitbbfa2f97014de8aa928485a07b722d792b09238f (patch)
tree281c076a5bf5477346e05337cdb35eba3bef2497 /lib/systems/inspect.nix
parent2fa2197a96fec6a15623bfab96b27d2b1fbe8949 (diff)
downloadnixlib-bbfa2f97014de8aa928485a07b722d792b09238f.tar
nixlib-bbfa2f97014de8aa928485a07b722d792b09238f.tar.gz
nixlib-bbfa2f97014de8aa928485a07b722d792b09238f.tar.bz2
nixlib-bbfa2f97014de8aa928485a07b722d792b09238f.tar.lz
nixlib-bbfa2f97014de8aa928485a07b722d792b09238f.tar.xz
nixlib-bbfa2f97014de8aa928485a07b722d792b09238f.tar.zst
nixlib-bbfa2f97014de8aa928485a07b722d792b09238f.zip
lib: Split Darwin into macOS and iOS
I noticed LLVM accepts `ios` as its own OS in platform triples; a
recent change as far as I know. I see it also accepts `macos*` for macOS
(formerly OS X). If it's now customary to distinguish iOS like so
(rather than guessing from the aarch, lets add both so our OSes are
still disjoint, and make Darwin a family instead.

But changing the config everywhere would probably be a mass rebuild, and
I'm not sure how well other software supports OSes besides "darwin", so
I'm keeping that the default name for macOS for now.
Diffstat (limited to 'lib/systems/inspect.nix')
-rw-r--r--lib/systems/inspect.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/lib/systems/inspect.nix b/lib/systems/inspect.nix
index ab220af46e30..4cdd26295471 100644
--- a/lib/systems/inspect.nix
+++ b/lib/systems/inspect.nix
@@ -21,9 +21,11 @@ rec {
     LittleEndian = { cpu = { significantByte = significantBytes.littleEndian; }; };
 
     BSD          = { kernel = { families = { inherit (kernelFamilies) bsd; }; }; };
+    Darwin       = { kernel = { families = { inherit (kernelFamilies) darwin; }; }; };
     Unix         = [ BSD Darwin Linux SunOS Hurd Cygwin ];
 
-    Darwin       = { kernel = kernels.darwin; };
+    MacOS        = { kernel = kernels.macos; };
+    iOS          = { kernel = kernels.ios; };
     Linux        = { kernel = kernels.linux; };
     SunOS        = { kernel = kernels.solaris; };
     FreeBSD      = { kernel = kernels.freebsd; };