about summary refs log tree commit diff
path: root/lib/options.nix
diff options
context:
space:
mode:
authorpennae <github@quasiparticle.net>2021-11-19 00:26:27 +0100
committerpennae <github@quasiparticle.net>2022-01-02 19:46:13 +0100
commitfc614c37c653637e5475a0b0a987489b4d1f351d (patch)
tree7b2470a3a67979ddcc51f18bb0d424f8e95908b1 /lib/options.nix
parent55daffc1c943bddb71dc89a606f8284f6d50f5bd (diff)
downloadnixlib-fc614c37c653637e5475a0b0a987489b4d1f351d.tar
nixlib-fc614c37c653637e5475a0b0a987489b4d1f351d.tar.gz
nixlib-fc614c37c653637e5475a0b0a987489b4d1f351d.tar.bz2
nixlib-fc614c37c653637e5475a0b0a987489b4d1f351d.tar.lz
nixlib-fc614c37c653637e5475a0b0a987489b4d1f351d.tar.xz
nixlib-fc614c37c653637e5475a0b0a987489b4d1f351d.tar.zst
nixlib-fc614c37c653637e5475a0b0a987489b4d1f351d.zip
nixos/documentation: split options doc build
most modules can be evaluated for their documentation in a very
restricted environment that doesn't include all of nixpkgs. this
evaluation can then be cached and reused for subsequent builds, merging
only documentation that has changed into the cached set. since nixos
ships with a large number of modules of which only a few are used in any
given config this can save evaluation a huge percentage of nixos
options available in any given config.

in tests of this caching, despite having to copy most of nixos/, saves
about 80% of the time needed to build the system manual, or about two
second on the machine used for testing. build time for a full system
config shrank from 9.4s to 7.4s, while turning documentation off
entirely shortened the build to 7.1s.
Diffstat (limited to 'lib/options.nix')
-rw-r--r--lib/options.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/options.nix b/lib/options.nix
index 5d52f065af08..53001a3113f9 100644
--- a/lib/options.nix
+++ b/lib/options.nix
@@ -177,7 +177,7 @@ rec {
         docOption = rec {
           loc = opt.loc;
           name = showOption opt.loc;
-          description = opt.description or (lib.warn "Option `${name}' has no description." "This option has no description.");
+          description = opt.description or null;
           declarations = filter (x: x != unknownModule) opt.declarations;
           internal = opt.internal or false;
           visible =