about summary refs log tree commit diff
path: root/lib/options.nix
diff options
context:
space:
mode:
authorAlois Wohlschlager <alois1@gmx-topmail.de>2024-02-03 16:13:04 +0100
committerAlois Wohlschlager <alois1@gmx-topmail.de>2024-02-03 19:01:39 +0100
commitd33127863ecda07ddd292d9bad7f8717f69430a0 (patch)
tree8d91256287e4f49b427ea7ad97321d87fd22250f /lib/options.nix
parentb8b232ae7b8b144397fdb12d20f592e5e7c1a64d (diff)
downloadnixlib-d33127863ecda07ddd292d9bad7f8717f69430a0.tar
nixlib-d33127863ecda07ddd292d9bad7f8717f69430a0.tar.gz
nixlib-d33127863ecda07ddd292d9bad7f8717f69430a0.tar.bz2
nixlib-d33127863ecda07ddd292d9bad7f8717f69430a0.tar.lz
nixlib-d33127863ecda07ddd292d9bad7f8717f69430a0.tar.xz
nixlib-d33127863ecda07ddd292d9bad7f8717f69430a0.tar.zst
nixlib-d33127863ecda07ddd292d9bad7f8717f69430a0.zip
lib: make deprecation warnings consistent
The deprecation warnings in lib were wildly inconsistent. Different
formulations were used in different places for the same meaning. Some warnings
used builtins.trace instead of lib.warn, which prevents silencing; one even
only had a comment instead. Make everything more uniform.
Diffstat (limited to 'lib/options.nix')
-rw-r--r--lib/options.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/options.nix b/lib/options.nix
index 9c10dfc8b36a..f5012848b05a 100644
--- a/lib/options.nix
+++ b/lib/options.nix
@@ -379,7 +379,7 @@ rec {
     if ! isString text then throw "literalExpression expects a string."
     else { _type = "literalExpression"; inherit text; };
 
-  literalExample = lib.warn "literalExample is deprecated, use literalExpression instead, or use literalMD for a non-Nix description." literalExpression;
+  literalExample = lib.warn "lib.literalExample is deprecated, use lib.literalExpression instead, or use lib.literalMD for a non-Nix description." literalExpression;
 
   /* Transition marker for documentation that's already migrated to markdown
      syntax. This is a no-op and no longer needed.