about summary refs log tree commit diff
path: root/lib/default.nix
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2020-11-18 12:12:34 -0500
committerJohn Ericson <John.Ericson@Obsidian.Systems>2020-11-19 00:07:14 -0500
commita6218c058b3e994779147dd7286606c750be7d73 (patch)
tree6d7bf3a5bbf43d953004ea725e9e4f6035d16184 /lib/default.nix
parentf01bfd6843cada594383a5ab67c01f30b571a185 (diff)
downloadnixlib-a6218c058b3e994779147dd7286606c750be7d73.tar
nixlib-a6218c058b3e994779147dd7286606c750be7d73.tar.gz
nixlib-a6218c058b3e994779147dd7286606c750be7d73.tar.bz2
nixlib-a6218c058b3e994779147dd7286606c750be7d73.tar.lz
nixlib-a6218c058b3e994779147dd7286606c750be7d73.tar.xz
nixlib-a6218c058b3e994779147dd7286606c750be7d73.tar.zst
nixlib-a6218c058b3e994779147dd7286606c750be7d73.zip
lib: Create `makeScopeWithSplicing`
It's ugly as hell, but I suppose it is needed to codify how to make
spliced package sets.
Diffstat (limited to 'lib/default.nix')
-rw-r--r--lib/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/default.nix b/lib/default.nix
index e3c1ed713463..f985266ed938 100644
--- a/lib/default.nix
+++ b/lib/default.nix
@@ -101,7 +101,7 @@ let
       noDepEntry fullDepEntry packEntry stringAfter;
     inherit (self.customisation) overrideDerivation makeOverridable
       callPackageWith callPackagesWith extendDerivation hydraJob
-      makeScope;
+      makeScope makeScopeWithSplicing;
     inherit (self.meta) addMetaAttrs dontDistribute setName updateName
       appendToName mapDerivationAttrset setPrio lowPrio lowPrioSet hiPrio
       hiPrioSet;